Opened 3 years ago

Closed 3 years ago

#3987 closed change (fixed)

Replace Google Maps map on eyeo.com with static image

Reported by: greiner Assignee: greiner
Priority: P3 Milestone:
Module: Websites Keywords: eyeo
Cc: saroyanm, trev Blocked By: #3996
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29340840/

Description

Background

We embed a small Google Maps frame on eyeo.com/contact to provide information about the location of our office. It seems that we don't really need all of its functionalities though, so we should be able to

  • display the location of the office
  • link to the Google Maps page

even without having to embed the Google Maps widget and thereby unnecessarily leaking data to maps.google.com.

What to change

Change History (9)

comment:1 Changed 3 years ago by saroyanm

  • Priority changed from Unknown to P3
  • Ready set

comment:2 Changed 3 years ago by greiner

  • Owner set to greiner

comment:3 Changed 3 years ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/web.eyeo.com/rev/52f7df39b043

comment:5 Changed 3 years ago by greiner

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 3 years ago by trev

  • Cc trev added
  • Resolution fixed deleted
  • Status changed from closed to reopened

I backed out this change in https://hg.adblockplus.org/web.eyeo.com/rev/474cde92adac. This was causing errors:

Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/opt/cms/cms/bin/generate_static_pages.py", line 154, in <module>
    generate_pages(repo, output_dir)
  File "/opt/cms/cms/bin/generate_static_pages.py", line 118, in generate_pages
    pagedata = process_page(source, locale, page)
  File "/opt/cms/cms/utils.py", line 91, in process_page
    site_url_override, localized_string_callback),
  File "/opt/cms/cms/utils.py", line 76, in get_page_params
    params["head"], params["body"] = converter()
  File "/opt/cms/cms/converters.py", line 283, in __call__
    result = self.resolve_includes(result)
  File "/opt/cms/cms/converters.py", line 278, in resolve_includes
    text
  File "/usr/lib/python2.7/re.py", line 151, in sub
    return _compile(pattern, flags).sub(repl, string, count)
  File "/opt/cms/cms/converters.py", line 266, in resolve_include
    result = converter()
  File "/opt/cms/cms/converters.py", line 282, in __call__
    result = self.get_html(*self._params[self._key])
  File "/opt/cms/cms/converters.py", line 334, in get_html
    result = md.convert(result)
  File "/usr/lib/python2.7/dist-packages/markdown/__init__.py", line 280, in convert
    self.lines = prep.run(self.lines)
  File "/usr/lib/python2.7/dist-packages/markdown/preprocessors.py", line 175, in run
    if self.markdown_in_raw and 'markdown' in attrs.keys():
AttributeError: 'tuple' object has no attribute 'keys'

comment:7 follow-up: Changed 3 years ago by greiner

  • Blocked By 3996 added

I cannot reproduce this issue with the latest cms version myself using the test environment so I created a new ticket for that (see #3996).

comment:8 in reply to: ↑ 7 Changed 3 years ago by saroyanm

Replying to greiner:

I cannot reproduce this issue with the latest cms version myself using the test environment so I created a new ticket for that (see #3996).

Thanks, yes me as well, trying to reproduce the issue using infrastructure, will continue in the ticket you created.

Last edited 3 years ago by saroyanm (previous) (diff)

comment:9 Changed 3 years ago by greiner

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.