Opened 3 years ago

Closed 3 years ago

#4008 closed change (fixed)

Some publicly accessible Mercurial repositories missing from index at hg.adblockplus.org

Reported by: barbaz Assignee: matze
Priority: P3 Milestone:
Module: Infrastructure Keywords:
Cc: arthur, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

(EasyList forum: https://forums.lanik.us/viewtopic.php?f=23&t=30028)

Environment

Lubuntu 14.04
SeaMonkey or Ubuntu-Chromium

How to reproduce

go to https://hg.adblockplus.org/ and look for link to "youtubefilters" repository

Observed behaviour

No link to https://hg.adblockplus.org/youtubefilters/ however there is a publicly accessible Mercurial repository at that URL.

This likely affects other repositories as well - for example, malwaredomains repo was seemingly moved but only the old location is linked.

Expected behaviour

See a "youtubefilters" link that can be clicked to access it, same as for e.g. ruadlist

Change History (4)

comment:1 follow-up: Changed 3 years ago by greiner

  • Cc arthur greiner matze added

@arthur @matze Any idea where that repository is located?

comment:2 in reply to: ↑ 1 Changed 3 years ago by barbaz

Replying to greiner:

@arthur @matze Any idea where that repository is located?

Since they seem to be quite busy, I tried to find out:

https://hg.adblockplus.org/sitescripts/file/tip/sitescripts/subscriptions/bin/updateMalwareDomainsList.py#l49

    config = get_config()
    section = 'subscriptionDownloads'
    repository = config.get(section, 'malwaredomains_repository')

https://hg.adblockplus.org/sitescripts/file/tip/sitescripts/utils.py#l58

def get_config():
    """
      Returns parsed configuration file (SafeConfigParser instance). File paths
      that will be checked: ~/.sitescripts, ~/sitescripts.ini, /etc/sitescripts,
      /etc/sitescripts.ini
    """

    paths = []

    # Allow SITESCRIPTS_CONFIG variable to override config path
    if 'SITESCRIPTS_CONFIG' in os.environ:
        paths.append(os.environ['SITESCRIPTS_CONFIG'])

But I don't know where to look for the "sitescripts.ini" in use (or if it's even published)...

comment:3 Changed 3 years ago by matze

  • Cc matze removed
  • Component changed from Unknown to Infrastructure
  • Owner set to matze
  • Priority changed from Unknown to P3
  • Ready set
  • Type changed from defect to change

Most of the Mercurial server setup is not automated anywhere, but done manually. Some repositories just have never been configured to be included with the index, like the youtubefilters one --

Regarding malwaredomains, however, please refer to #392.

comment:4 Changed 3 years ago by matze

  • Resolution set to fixed
  • Status changed from new to closed

Both the youtubefilters and facebookfilters repositories are now included with the index.

Note: See TracTickets for help on using tickets.