Opened 4 years ago

Closed 3 months ago

#4026 closed defect (rejected)

First-run page and warning not shown after reinitializing filter subscriptions

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 1.11.0.1597
Chrome 50 / Windows 10

How to reproduce

  1. Install latest ABP build.
  2. [ABP Icon] > [Options] > Delete all of the initial filter subscriptions.
  3. Close and reopen Chrome.
  4. [ABP Icon] > [Options] > Observe EasyList was restored (expected).
  5. Observe the first-run page is not re-shown with a warning that filters were reinitialized.

Observed behaviour

Subscriptions are reinitialized but the first-run page with the warning is not displayed.

Expected behaviour

The first-run page is opened again displaying the warning that filters were reinitialized.

Change History (2)

comment:1 Changed 4 years ago by Ross

This appears to be a regression caused by #3719.

comment:2 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.