Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4032 closed change (fixed)

Add URL autocompletion in URL bar

Reported by: mario Assignee:
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.5.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: Blocked By: #4117
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by mario)

Background

In order to make working with ABB faster, we'd like to introduce autocompletion of typed URLs in the URL bar.

What to change

As soon as a user starts to type into the URL bar, test if the typed string matches the beginning of a URL which has been visited before and perform the following actions:

  1. If the typed string matches a URL that has been visited before and if the last pressed key was not backspace:
    1. Display the remaining characters of the most relevant URL* as autocompleted text as shown in this screenshot (only test and autocomplete the hostname - no full URLs with parameters)
    2. Upon pressing enter, the autocompleted URL is visited
    3. Upon pressing any other key, go back to 1.
  2. If the typed string does not match a URL that has been visited before or if the last pressed key was backspace:
    1. Do not display any URL autocompletion as shown in this screenshot

*most relevant URL: in case the typed string matches more than one URL, display the URL that has been visited the most.

Style/Components

Please display and treat the autocompleted text as ordinary selected text:

  1. Use the standard font/size/color as well as standard selection highlight color
  2. Upon pressing backspace once the selected text is removed as shown in this screenshot
  3. Upon pressing backspace more than once the selected text is removed and the previously typed characters are removed one by one

Remark for testers

Please note, that condition 2. ("don't display any URL autocompletion") can be overruled by #4033 which introduces autocompletion for search terms.

Attachments (2)

url_bar_autocomplete_url_NA.PNG (107.9 KB) - added by mario 3 years ago.
url_bar_autocomplete_url.PNG (51.5 KB) - added by mario 3 years ago.

Download all attachments as: .zip

Change History (19)

Changed 3 years ago by mario

Changed 3 years ago by mario

comment:1 Changed 3 years ago by mario

  • Description modified (diff)

comment:2 Changed 3 years ago by mario

  • Description modified (diff)

comment:3 Changed 3 years ago by mario

  • Description modified (diff)

comment:4 Changed 3 years ago by mario

  • Priority changed from P3 to P2

comment:5 Changed 3 years ago by mario

  • Summary changed from URL autocompletion in URL bar to Add URL autocompletion in URL bar

comment:6 Changed 3 years ago by pavelz

Should be folded into https://issues.adblockplus.org/ticket/4033, see the discussion there.

comment:7 Changed 3 years ago by mario

As discussed in #4033, we'll keep the issues separate. We wanted to keep the scope of each issue simple (especially since they're closely related but not dependant on each other) and we wanted to keep testability as simple as possible. Nothing speaks against implementing them both at the same time though.

comment:8 Changed 3 years ago by mario

  • Ready set

comment:9 Changed 3 years ago by pavelz

@mario ok then please change the issue description to refer to requested behavior of #4033 in point 2. As described in isolation, the QA would fail - an autocompletion will still be displayed.

Also we need a behavior confirmation: a visited URL can naturally be not only the hostname but also path and parameters. Due to today's common practice of request redirections (on behalf of detected user agent, geolocation etc.), such extended URL can be even _the most visited one_. Is this feature asking for autocompleting just the hostname, or the full URL, if it's the most visited one? Our common sense is saying hostname only. On desktop browsers, full URL is always an option, but the selectability and editability on desktop is less awkward experience.

comment:10 Changed 3 years ago by mario

  • Description modified (diff)

comment:11 Changed 3 years ago by mario

  • Description modified (diff)

ok then please change the issue description to refer to requested behavior of #4033 in point 2.

Changed

Is this feature asking for autocompleting just the hostname, or the full URL, if it's the most visited one? Our common sense is saying hostname only.

Yes, it was intended to only autocomplete the hostname. Changed the Description accordingly.

comment:12 Changed 3 years ago by pavelz

  • Blocked By 4117 added

comment:13 Changed 3 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:14 Changed 3 years ago by pavelz

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:15 Changed 3 years ago by pavelz

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:16 Changed 3 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

comment:17 Changed 3 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

If the typed string matches the URL that has been visited before and if the last pressed key was not backspace:

  • The remaining characters of the most relevant URL are displayed as autocompleted text.
  • Upon pressing enter, the autocompleted URL is visited.
  • Upon pressing any other key, I was returned to step 1.

If the typed string does not match a URL that has been visited before or if the last pressed key was backspace:

The URL autocompletion is not displayed.

ABB 1.5.0 (1066)
iPhone 6s Plus
iOS 9.3.1

Note: See TracTickets for help on using tickets.