Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#4035 closed defect (fixed)

A page gets closed if it was opened as popup and contains blocked resources

Reported by: scheer Assignee: pavelz
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.4.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by pavelz)

When the user attempts to open certain sites from news.google.com, the page starts opening as a new tab as expected, but gets closed immediately. Some of these pages are zeit.de and computerwoche.de.

Environment

ABB 1.3.2
iPhone 6 Plus S
iOS 9.3.1

How to reproduce

  1. Visit news.google.com
  2. Open an article from zeit.de

Observed behaviour

The opened window is immediately closed and the user is brought back to news.google.de.

Expected behaviour

The news article window from zeit.de should remain open.

Attachments (1)

CoreTime.txt (52.2 KB) - added by scheer 15 months ago.

Download all attachments as: .zip

Change History (8)

Changed 15 months ago by scheer

comment:1 Changed 15 months ago by mario

  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 15 months ago by pavelz

  • Owner set to pavelz

The bug is triggered by the new ABP popup handling code. When popup creation is catched in webNavigation.onCreatedNavigationTarget, extension creates an additional temporary listener to webRequest.onBeforeRequest, restricted to resourceType=main_frame. Due to a bug in Kitt core, this additional listener is called for ALL requests from the popup, not only main_frame. If there is a resource in the popup which has to be blocked, this new listener considers it main_frame and closes the whole popup as blocked. In case of zeit.de, the blocked content is either from doubleclick.net or de.com. But it would happen equally for any other page with blockable content, if it happens to get opened as popup.

comment:3 Changed 15 months ago by pavelz

  • Cc mario added
  • Description modified (diff)
  • Summary changed from chrome.tabs.remove closes zeit.de when opened from news.google.com to A page gets closed if it was opened as popup and contains blocked resources

@mario reworded issue summary, please review

comment:5 Changed 15 months ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 15 months ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

comment:7 Changed 15 months ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

I have now opened varying pages from news.google.com with no adverse effects. Opening previous culprits such as zeit.de now open with no issues at all.

ABB 1.4.0 (996)
iPhone 6s Plus
iOS 9.3.1

Note: See TracTickets for help on using tickets.