Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4056 closed change (fixed)

Update adblockpluscore dependency to revision b791dfaa66c6

Reported by: kzar Assignee: kzar
Priority: P1 Milestone: Adblock-Plus-1.12-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian, Ross, scheer Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29342846/

Description

Background

This change will import #4054 which fixes a recent regression with Element.getSelectorsByDomain.

What to change

Update the adblockpluscore dependency to revision b791dfaa66c6. No other changes will be imported.

Hints for testers

Ensure element hiding still works as expected, especially that when a subscription is disabled its rules stop applying.

Change History (6)

comment:1 follow-up: Changed 3 years ago by sebastian

Perhaps we should land this review as well before updating the dependency, assuming that it will get through review today or on Monday. If we aren't going to have a release next week (we won't) we don't have to rush this dependency update.

comment:2 in reply to: ↑ 1 Changed 3 years ago by kzar

  • Review URL(s) modified (diff)

Replying to sebastian:

Perhaps we should land this review as well before updating the dependency, assuming that it will get through review today or on Monday. If we aren't going to have a release next week (we won't) we don't have to rush this dependency update.

I would rather update the dependency again if that review lands personally. It's a fairly bad regression and as I keep learning - rushing things through often ends in disaster. (I also plan to write unit tests along with that change.)

comment:3 Changed 3 years ago by sebastian

Fine with me, but then please split those changes out of #235 that we can track it separately, since it most likely won't land in the next release.

comment:4 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockpluschrome/rev/ee0112b5730f

comment:5 Changed 3 years ago by kzar

  • Cc Ross scheer added
  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

ABP 1.11.0.1606
Chrome 31, 45, 50 / Windows 7
Chrome 32, 49 / OS X 10.11
Chrome 49 / Ubuntu 14.04
Opera 36 / Ubuntu 14.04

Note: See TracTickets for help on using tickets.