Opened 3 years ago

Closed 3 years ago

#4058 closed defect (duplicate)

Some CSS-filters broken in Firefox Nightly 48/49+

Reported by: metasieben Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Firefox: 48+ rev >= ae7413abfa4d3954a6a4ce7c1613a7100f367f9a
AdblockPlus: 2.7.3.4174-beta

Every Nightly version after 2016-04-18 shows this behaviour.

How to reproduce

  1. add this to the custom filters: twitch.tv##div[class='clearfix upsell-banner recent-past-broadcast']
  2. go here: https://www.twitch.tv/previouslyrecorded_live

Observed behaviour

  1. (if channel ist offline) there is a banner >Watch PreviouslyRecorded_Live's Last Broadcast!< with the class 'div.clearfix.upsell-banner.recent-past-broadcast' which should not be visible.

Expected behaviour

  1. (if channel ist offline) banner with the class 'div.clearfix.upsell-banner.recent-past-broadcast' should be blocked.

somewhere between these Nightly versions(18.04. / 19.04.) something changed in Firefox and ADP is no longer able to block these styles?

here the regression-range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1f16d3da9280e40ada252acf8110b91ee1edbb08&tochange=ae7413abfa4d3954a6a4ce7c1613a7100f367f9a

Change History (5)

comment:2 Changed 3 years ago by mapx

  • Cc trev added

comment:3 Changed 3 years ago by trev

Do you happen to use Mac OS X? Because bug 1187099 is back and I just filed #4139 on addressing this.

comment:4 Changed 3 years ago by metasieben

yes, i am.

comment:5 Changed 3 years ago by trev

  • Resolution set to duplicate
  • Status changed from new to closed

Let's resolve this issue as a duplicate then, #4139 is already under review.

Note: See TracTickets for help on using tickets.