Opened 4 years ago

Closed 3 years ago

#4063 closed defect (fixed)

Missing picture in the "You're in control" screen when displayed in landscape mode

Reported by: michal.kuric Assignee:
Priority: P3 Milestone:
Module: Adblock-Browser-for-iOS Keywords:
Cc: mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mario)

Environment

ABB v1.4.0 (core 1.3.7-qa) - release 956
iPhone 5S - iOS 9.3.2

How to reproduce

  1. Install ABB 1.4.0
  2. Open the app
  3. On the first run slide "Browse in peace", tap the button "Only one more step" to see the next slide
  4. On the slide "You're in control", tilt your iPhone display ABB in landscape mode

Observed behaviour

The settings picture is resized into extremely small dimensions so it looks like a tiny rectangle as shown in this screenshot.

Expected behaviour

The settings picture should still be displayed in a reasonable size and occupy the remaining whitespace.

Attachments (2)

IMG_0666.jpg (77.7 KB) - added by michal.kuric 4 years ago.
iphone5_image_ok.png (569.1 KB) - added by mario 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by michal.kuric

comment:1 Changed 4 years ago by mario

  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from Missing picture in "You're control" screen when browsing in a landscape mode to Missing picture in the "You're in control" screen when displayed in landscape mode

Changed the description to include the screenshot.
I can reproduce this issue on an iPhone 6 even though it's not as bad as on the iPhone 5s. Presumably due to the difference in screen resolution.

comment:2 follow-up: Changed 4 years ago by pavelz

In any case, needs design decision. The picture clearly can't fit in landscape. So should it be displayed cropped, or not at all?

Changed 4 years ago by mario

comment:3 in reply to: ↑ 2 Changed 4 years ago by mario

Replying to pavelz:

In any case, needs design decision. The picture clearly can't fit in landscape. So should it be displayed cropped, or not at all?

Please have a look at Michal's screenshot and compare it to a screenshot I've just taken on an iPhone 5.

The former shows the glitch as outlined in the issue.
The latter was captured when already forcing ABB into landscape mode before navigating to the second run slide.

I admit, that the picture in the second screenshot is fairly small and we should think about giving it more space. If you follow the instructions outline in the issue, you will, however, run into a easily reproducible bug: The image is scaled too small.

comment:4 Changed 3 years ago by jand

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 3 years ago by michal.kuric

  • Resolution fixed deleted
  • Status changed from closed to reopened

The picture on iP5S running iOS 9.3.2 - ABB 1.5.0-QA (Build 1070) is exactly the same as before. Testing on iPhone 5 might not help even if the resolution is the same. What iOS version are you using Mario? I've tested on iPhone 5c running iOS 8.4.1 and it brings the same result as the one from you

comment:6 Changed 3 years ago by pavelz

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.