Opened 4 years ago

Closed 5 months ago

#4066 closed defect (rejected)

Too many subscriptions with content blocking enabled causes Safari to crash

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: kzar, sebastian Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by sebastian)

Environment

ABP 1.11.0.1606
Safari 9 / OS X 10.11

Reproduced twice.

How to reproduce

  1. Install ABP. Open ABP options.
  2. Enable the Adblock warning subscription.
  3. Add four or five more EasyList subscriptions.
  4. In the [General] tab, enable content blocking.
  5. Observe the error about too many rules appear.
  6. Quit Safari.
  7. Restart Safari.
  8. Observe Safari starts, then quits 1-2 seconds later.

Observed behaviour

Safari starts, displays the OS X spinner and then quits. Sometimes the ABP popup can be opened before the quit.

Expected behaviour

ABP and its functionality/options to not cause Safari to quit.

Notes

See 3687#comment:31

Change History (6)

comment:1 Changed 4 years ago by Ross

The second time the testing VM warned about low disk space, attempting to figure out if that is related or the cause (I'm assuming content blocker creates a several MB json file somewhere?)

Last edited 4 years ago by Ross (previous) (diff)

comment:2 Changed 4 years ago by sebastian

  • Cc kzar sebastian added

comment:3 Changed 4 years ago by kzar

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Platform changed from Chrome to Safari
  • Summary changed from Too many subscriptions with content blocker enabled causes Safari to quit to Too many subscriptions with content blocking enabled causes Safari to crash

comment:4 Changed 4 years ago by kzar

  • Description modified (diff)

comment:5 Changed 4 years ago by sebastian

  • Description modified (diff)

comment:6 Changed 5 months ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

I'm closing all issues related to the legacy Safari extension, as it has been discontinued in favor of an App Extension that doesn't share any code with the old extension.

Note: See TracTickets for help on using tickets.