Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4069 closed change (fixed)

Upgrade Nginx Version

Reported by: matze Assignee: matze
Priority: P1 Milestone:
Module: Infrastructure Keywords:
Cc: fhd Blocked By:
Blocking: #4068 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29343000/
https://codereview.adblockplus.org/29343006

Description

It's time, again:

debug: Puppet::Type::Package::ProviderApt: Executing '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install nginx=1.8.1-1+precise0'
err: /Stage[main]/Nginx/Package[nginx]/ensure: change from purged to 1.8.1-1+precise0 failed: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install nginx=1.
8.1-1+precise0' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
E: Version '1.8.1-1+precise0' for 'nginx' was not found
 at /tmp/vagrant-puppet-2/modules-0/nginx/manifests/init.pp:28
vagrant@hg1:~$ apt-cache show nginx | grep version -i
Version: 1.10.0-0+precise0
Version: 1.1.19-1ubuntu0.8
Version: 1.1.19-1ubuntu0.7
Version: 1.1.19-1

We need to upgrade Nginx to version 1.10.0-0+precise0

Change History (6)

comment:1 Changed 3 years ago by matze

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4069 - Upgrade Nginx to version 1.10.0-0+precise0

comment:3 Changed 3 years ago by matze

  • Resolution set to fixed
  • Status changed from reviewing to closed

The patch-set has landed, deployment throughout all web-servers will take a while.

comment:4 Changed 3 years ago by matze

  • Review URL(s) modified (diff)

comment:5 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4069 - Drop SPDY in favour of HTTP/2

comment:6 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4069 - Upgrade Nginx to version 1.10.1-0+precise0

Note: See TracTickets for help on using tickets.