Opened 4 years ago

Closed 4 years ago

#4077 closed defect (rejected)

Initialization logic is missing out subscriptions and first-run page

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 1.11.0.1606
Chrome 31, 45, 50 / Windows 7

How to reproduce

  1. Install ABP.
  2. Delete all of the subscriptions.
  3. Close and reopen Chrome.
  4. Observe EasyList is subscribed to again (intended).
  5. Observe the Warning Removal List was not added again (unintended?)
  6. Observe no first-run page was opened with the warning (as described in #3719).
  7. Delete all of the subscriptions again.
  8. Add your own custom filter (anything).
  9. Close and reopen Chrome.
  10. Observe EasyList was not subscribed to again (due to the filter - intended?).

Observed behaviour

The first-run page with warning is never shown. Not all default subscriptions are re-added after restart. If custom filters exist, default subscriptions are not subscribed to again.

Expected behaviour

The full set of default subscriptions along with their default states to be subscribed to again. The first-run page with the warning to appear. Subscriptions to

Change History (2)

comment:1 Changed 4 years ago by Ross

  • Cc sebastian added
  • Component changed from Unknown to Platform

comment:2 Changed 4 years ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.