Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4095 closed change (fixed)

Update ABP bundle to version 1.12

Reported by: mario Assignee:
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.5.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Background

A new version of ABP for Chrome/Opera/Safari (version 1.12) has been released as of 2016-06-01. In order to stay up to date, we want to update the ABP bundle in ABB.

The list of changes for ABP 1.12 for Chrome/Opera/Safari can be found here.

What to change

Replace the ABP extension bundle with the provided crx file based on ABP 1.12 for Chrome/Opera/Safari.

Remarks

ABP 1.12 introduces a lot of changes/fixes. Not all of them affect ABB, however we need to regress the most important of them in order to make sure we don't introduce additional bugs. Some changes may require explicit attention while implementing the new bundle.
Specifically the following issues might directly/indirectly affect ABB's behaviour:

  • #3844: Adblock Plus breaks CSSStyleSheet.deleteRule()
  • #3687: Add experimental support for content blockers on Safari 9 (Note, this is Safari 9 for desktop)
  • #3719: Refactor initialization logic [and add a hook for AdBlock]
  • #4038: Increase SELECTOR_GROUP_SIZE used by addElemHideSelectors
  • #235: Performance of ElemHide.getSelectorsByDomain() needs to be improved
  • #2687: Shadow DOM breaks layout when using "report a problem" dialog on blogger.com
  • #3699: Patch DOM API in order to prevent disabling the injected stylesheet
  • #3771: Update adblockpluscore dependency and adapt filter validation (specifically #3659)
  • #3824: Move "use strict" into IIFE for compatibility with Kitt
  • #3829: Merge add-subscription and subscriptions.add messages
  • #3788: Keep track of new pages in Safari without using canLoad

Change History (4)

comment:2 Changed 3 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 3 years ago by pavelz

  • Milestone set to Adblock-Browser-for-iOS-next

comment:4 Changed 3 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

. #3844: Adblock Plus breaks CSSStyleSheet.deleteRule()

  • Website now plays all videos and shows no adverts.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #3687: Add experimental support for content blockers on Safari 9 (Note, this is Safari 9 for desktop)

  • This is actually set to blocked. However, I have tested based on the change made here and found no abnormal behaviour because of it.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #3719: Refactor initialization logic [and add a hook for AdBlock]

  • Configured subscriptions and custom filters are preserved when the browser is restarted.
  • On first run, the default subscriptions is automatically added, but currently only English is subscribed across all languages. Please see #4326.
  • The third point in the hints for testers does not apply to ABB, as it refers to the installation page.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #4038: Increase SELECTOR_GROUP_SIZE used by addElemHideSelectors

  • Element hiding is not an available function in ABB iOS.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #235: Performance of ElemHide.getSelectorsByDomain() needs to be improved

  • Element hiding is not an available function in ABB iOS.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #2687: Shadow DOM breaks layout when using "report a problem" dialog on blogger.com

  • I tested this on ABP for Chrome too and everything functioned as intended, but when attempting this on ABB the layout of the ‘give feedback’ option broke. However, the issue experienced on ABB iOS also occurs on Chrome iOS and Safari iOS.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #3699: Patch DOM API in order to prevent disabling the injected stylesheet

  • Element hiding is not an available function in ABB iOS. But, I did check www.extremetech.com and it functions as intended.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #3771: Update adblockpluscore dependency and adapt filter validation (specifically #3659)

  • There is currently no way to add manual filters in ABB iOS.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #3824: Move "use strict" into IIFE for compatibility with Kitt

  • This change doesn’t appear to have caused any underlying issues.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #3829: Merge add-subscription and subscriptions.add messages

  • I am able to subscribe to subscriptions correctly, but as stated above, there is still an issue with the default filter language being applied. Please see #4326.
  • ABB 1.5.0 (1058), iOS 9.3.1.

. #3788: Keep track of new pages in Safari without using canLoad

  • This refers to Safari only. That being said, I have worked through any similarities that ABB has and checked them accordingly.
  • ABB 1.5.0 (1058), iOS 9.3.1.
Note: See TracTickets for help on using tickets.