Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4101 closed defect (fixed)

Adblock Plus >= 1.12 is causing some websites to hang with older versions of Chrome

Reported by: favorite Assignee: kzar
Priority: P3 Milestone: Adblock-Plus-1.12.2-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: kzar, sebastian, Ross, scheer Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29348869/

Description (last modified by kzar)

Environment

Windows 7 (x64);
Google Chrome version 39.0.2171.71
Adblock Plus 1.12 with RU AdList: BitBlock

How to reproduce

  1. Open http://pikabu.ru/story/predsedatel_evropeyskogo_soveta_udachno_poshutil_pro_match_angliyaislandiya_podpischik_eshchyo_udachnee_ego_podkolol_4301914
  2. Wait a couple of minutes

Observed behaviour

The tab hangs / crashes.

Expected behaviour

The tab does not hang.

Notes

Change History (17)

comment:1 in reply to: ↑ description Changed 3 years ago by favorite

Replying to favorite:

Environment

OS: Windows 7 (x64);
Browser version: Google Chrome ver. 39.0.2171.71;
AdBlock Plus version 1.12, Filter lists - RuAdList+EasyList, Fanboy's Social Blocking List.

How to reproduce

With the new version of the ABP(1.12) began to hang some sites.
With off ABP are working properly.

...

Observed behaviour

Web pages hang cease to operate normally, no matter what do not react.

Expected behaviour

For Web pages do not hang, continued to operate normally.

comment:2 follow-up: Changed 3 years ago by kzar

Hi favorite,

Thanks for filing an issue, I need some more information before I can investigate however.

Please can you provide some easy to follow steps in the "How to reproduce" section? (Especially important is a link to a specific page that causes the problem.)

Thanks, Dave.

comment:3 Changed 3 years ago by kzar

  • Cc kzar added
  • Component changed from Unknown to Platform

comment:4 in reply to: ↑ 2 Changed 3 years ago by favorite

Replying to kzar:

Hi favorite,

Thanks for filing an issue, I need some more information before I can investigate however.

Please can you provide some easy to follow steps in the "How to reproduce" section? (Especially important is a link to a specific page that causes the problem.)

Thanks, Dave.

Hello!

We go to the website pikabu.ru there any open post (for example: http://pikabu.ru/story/predsedatel_evropeyskogo_soveta_udachno_poshutil_pro_match_angliyaislandiya_podpischik_eshchyo_udachnee_ego_podkolol_4301914), wait a couple of minutes and the web-page hangs. List of filters must be present "Fanboy's Annoyances".

It's about old version of Google Chrome.
Through e-mail contact with Sebastian managed to know what was the case in older versions, up to and including 43 (through Wladimir Palant). In version 1.11 there were no problems. But began in 1.12. Plus there is some flickering advertising when loading a web page.
Example: https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/6027033060/original/bad.png
Link: http://www.mangareader.net/naruto/1
Appears at startup on the fraction of a second web page, and disappears if to refresh page or go to next page.

In AdBlock with release of version 3.0 appeared same problem.

comment:5 Changed 3 years ago by kzar

  • Cc sebastian added
  • Description modified (diff)
  • Summary changed from The new version of ABP(1.12) began to hang sites. to Adblock Plus >= 1.12 is causing some websites to hang with older versions of Chrome

Great thanks, that's enough information for me to get started. I've updated the issue and will try to reproduce the problem when I get a chance.

comment:6 Changed 3 years ago by kzar

  • Sensitive unset

comment:7 Changed 3 years ago by kzar

I've just failed to reproduce this on both Windows XP and Windows 7 using Chrome 39 and Adblock Plus 1.12.1.1627.

  • Please could you check the issue description has the correct steps to reproduce and other details?
  • If so could you verify that the issue still happens for the example page that you mentioned?
  • Finally could you make sure that you still experience the problem when using the latest dev build version of Adblock Plus (1.12.1.1627)?

comment:8 in reply to: ↑ description Changed 3 years ago by favorite

Replying to favorite:

Environment

Windows 7 (x64);
Google Chrome version 39.0.2171.71 (40.0.2214.111 too)
Adblock Plus 1.12 with RuAdList+EasyList, Fanboy's Social Blocking List, RU AdList: BitBlock.

How to reproduce

  1. Open http://pikabu.ru/story/predsedatel_evropeyskogo_soveta_udachno_poshutil_pro_match_angliyaislandiya_podpischik_eshchyo_udachnee_ego_podkolol_4301914
  2. Wait a couple of minutes

Observed behaviour

The tab hangs / crashes.

Expected behaviour

The tab does not hang.

Notes

  • Reported as not happening in version 1.11 of Adblock Plus.
  • Reported as happening in AdBlock since version 3.
  • Reported as only happening with older versions of Chrome (<= 43).

comment:9 Changed 3 years ago by kzar

  • Description modified (diff)

comment:10 follow-up: Changed 3 years ago by kzar

  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

Thanks, finally managed to reproduce this with Chrome 39 and Adblock Plus 1.12.1. (Turned out the BitBlock subscription was the important one.)

comment:11 in reply to: ↑ 10 Changed 3 years ago by favorite

Replying to kzar:

Thanks, finally managed to reproduce this with Chrome 39 and Adblock Plus 1.12.1. (Turned out the BitBlock subscription was the important one.)

I've tried a few combinations of filter lists.
Combination of filters due to which page hung:
RuAdList+EasyList + Fanboy's Social Blocking List;
RuAdList+EasyList + RU AdList: BitBlock;
and
RuAdList+EasyList + Fanboy's Social Blocking List + RU AdList: BitBlock.

On other filter lists all worked fine, checked only once, month ago*

comment:12 Changed 3 years ago by kzar

  • Description modified (diff)
  • Owner set to kzar

Tracked the problem down to a couple of commits, looks likely it's caused by the MutationObserver stuff we changed for #3840. Will continue to investigate.

comment:13 follow-up: Changed 3 years ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Yep, that was the problem. The MutationObserver was triggering itself. (Apparently with older versions of Chrome element.style.setProperty is enough to trigger a MutationObserver even if the new value is the same as the old one...)

comment:14 in reply to: ↑ 13 Changed 3 years ago by favorite

Replying to kzar:

Yep, that was the problem. The MutationObserver was triggering itself. (Apparently with older versions of Chrome element.style.setProperty is enough to trigger a MutationObserver even if the new value is the same as the old one...)

Can I convey this message to AdBlock support?

comment:15 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4101 - Prevent runaway MutationObservers

comment:16 Changed 3 years ago by kzar

  • Cc Ross scheer added
  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:17 Changed 3 years ago by rraceanu

  • Verified working set

Tab doesn't hang or crash after 20 minutes+.

Chrome 39 - Win 7 x64
ABP 1.21.1.1644.

Last edited 3 years ago by rraceanu (previous) (diff)
Note: See TracTickets for help on using tickets.