Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#411 closed defect (incomplete)

Adblock Plus doesn't hide a specific element on cinema-city.co.il

Reported by: arthur Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: arthur, smultron45@… Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Firefox 29
Windows 8.1 Pro x64 Update 1
Adblock Plus 2.6.0.3804
Element Hding Helper 1.3.0.463

How to reproduce

  1. Go to http://www.cinema-city.co.il/
  2. Select this banner on the left via Element Hiding Helper until this filter is suggested like in the screenshots:
    cinema-city.co.il##.layerItem.34.ItemClass-10-2-34
    

Observed behaviour

The banner isn't removed in the composer preview and also not if you add the filter to ABP.

Expected behaviour

The banner should be hidden in the composer preview and also if you add it to ABP. If you select another hiding filter with the "style" tag, it works as expected.

Attachments (2)

working.png (301.2 KB) - added by arthur 6 years ago.
not_working.png (369.7 KB) - added by arthur 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by arthur

Changed 6 years ago by arthur

comment:1 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:2 Changed 6 years ago by barbaz

This isn't an Adblock Plus issue. What you're seeing is caused by the fact that

.34

is not a valid CSS selector. The following filter will work:

cinema-city.co.il##.layerItem.ItemClass-10-2-34[class*=" 34"]

comment:3 Changed 6 years ago by arthur

  • Resolution set to invalid
  • Status changed from new to closed

Thanks!

comment:4 Changed 6 years ago by mapx

if the filter

cinema-city.co.il##.layerItem.34.ItemClass-10-2-34

is suggested by EHH, it's something wrong with the same EHH

comment:5 Changed 6 years ago by barbaz

A more EHH-suitable filter suggestion than what I wrote above would be

cinema-city.co.il##.layerItem[class~="34"].ItemClass-10-2-34

(Apparently, any id or whitespace-separated fragment of a class that starts with a number cannot be used with the #id or .class CSS selectors.)

comment:6 Changed 6 years ago by arthur

@mapx
EHH simply suggests a filter according to what's in the source of a page.

Note: See TracTickets for help on using tickets.