Opened 3 years ago

Closed 23 months ago

#4123 closed defect (worksforme)

Support link points to Chrome support forum page

Reported by: scottlow Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian, oleksandr, Ross Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by scottlow)

Environment

Adblock Plus for Edge

How to reproduce

  1. Install Adblock Plus from the Windows Store
  2. Open options page
  3. Click on "General" tab and then hover over the "file a request here" link
  4. Click on the link

...

Observed behaviour

Link points to https://adblockplus.org/redirect?link=chrome_support&lang=en-us. Clicking on it leads to the Chrome support forum.

Expected behaviour

Link points to a Microsoft Edge/general support forum page

Additional information

This was filed by one of our internal testers who found this while self-hosting Adblock Plus

Change History (4)

comment:1 Changed 3 years ago by scottlow

  • Description modified (diff)
  • Sensitive unset

comment:2 Changed 2 years ago by sebastian

  • Cc sebastian oleksandr Ross added
  • Owner sebastian deleted

In early versions of Adblock Plus for Microsoft Edge, the logic in the info module still didn't understood Microsoft Edge (but only Chromium) user agent strings. This has been addressed in #3704. Latest with the current development build (but possibly already before) this should be fixed.

Ross and Ollie, can both of you confirm, that this is fixed now?

comment:3 Changed 2 years ago by oleksandr

Confirmed.

comment:4 Changed 23 months ago by sebastian

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.