Opened 3 years ago

Closed 16 months ago

Last modified 16 months ago

#4126 closed defect (fixed)

Facebook and Google Plus share descriptions do not mention Microsoft Edge

Reported by: scottlow Assignee:
Priority: P5 Milestone:
Module: Websites Keywords: goodfirstbug, content
Cc: sebastian, oleksandr, greiner, juliandoucette, jeen, lisabielik, wspee Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Cross Platform

How to reproduce

  1. Click "Share this number" in the Adblock Plus popup
  2. Click either Facebook or G+ icon

...

Observed behaviour

The resulting share cards have descriptions that do not mention "Microsoft Edge"

Expected behaviour

The resulting share cards have descriptions that mention "Microsoft Edge" as a supported platform

Change History (13)

comment:1 Changed 22 months ago by sebastian

  • Cc sebastian oleksandr greiner added
  • Owner sebastian deleted
  • Platform changed from Unknown / Cross platform to Edge

comment:2 Changed 22 months ago by sebastian

  • Component changed from Unknown to User-Interface

As far as I understand, on Google Plus we just share a link and it is not possible to include any text there (see #349), and on Facebook this text is shared which doesn't include the name of any other browser either. Unless I miss something, this sounds like a feature request to include the browser name into the shared message on Facebook. Fine with me, but this would be up to the UI team.

comment:3 Changed 22 months ago by greiner

  • Cc juliandoucette added
  • Component changed from User-Interface to Websites

It doesn't sound like the text he's referring to is the one we pass to the share dialog but the one that the social network's crawler retrieves from our website's meta tags:

Adblock Plus is the most popular ad blocker available for Firefox, Chrome, Opera, Safari, Android and Internet Explorer. Block all annoying ads all over the web: remove video ads on YouTube, block Facebook ads, get rid of pop-ups and much more. On Google Chrome, Adblock Plus is one of the fastest growing extensions ever. Adblock Plus is used on over 100 million devices. Download online for free now!

comment:4 Changed 21 months ago by juliandoucette

Thank you scottlow!

  • sebastian is right that this is more of a feature request than a bug
  • greiner is right that this text comes from our website's meta data (our homepage)
  • this text is changing in adblockplus.org 2.x
    • no mention of "IE" or "Edge" is planned
  • I will forward this request to the product team

comment:5 Changed 20 months ago by juliandoucette

  • Cc jeen lisabielik wspee added
  • Keywords goodfirstbug content added

CC Jeen, Lisa

I don't remember if I pointed this out to you in the ABP spec. Will you please confirm that you are aware of this issue and will or will not address it directly in new abp.org content?

comment:6 Changed 20 months ago by juliandoucette

  • Milestone set to adblockplus.org 2.1 index page
  • Priority changed from Unknown to P5

comment:7 Changed 18 months ago by juliandoucette

  • Milestone adblockplus.org 2.1 index page deleted

Milestone adblockplus.org 2.1 index page deleted

comment:8 Changed 18 months ago by jeen

Thanks for pointing this out.

It seems like the site metadata is missing this and should be included. I would suggest we update the homepage meta data to read:

Block annoying ads and more with Adblock Plus, the best ad blocker available on Chrome, Firefox, Safari, Edge, Internet Explorer, Android, iOS and more.

The above proposed description fits within the 160 character count, so the whole text is likely to be displayed properly in search results. I will update the specs accordingly.

You can find metadata overview here: https://docs.google.com/spreadsheets/d/113bQySBp2DTu1TPXGh5v1GIWSysGOSrgQNlCO_c2Coo/edit?usp=sharing.

comment:9 Changed 18 months ago by juliandoucette

Thanks Jeen!

Has this text already been approved by C&T and Legal? If not, will you see that it does and get back to me (preferably via gitlab issue/board/spec)?

comment:10 Changed 18 months ago by jeen

@juliandoucette this was created by Lisa, but will run it by legal as well. I'll move this over to GitLab (https://gitlab.com/eyeo/web.adblockplus.org/issues/14)

comment:11 Changed 17 months ago by jeen

We have decided to not include Edge as a supported platform since it is still in beta.

comment:12 Changed 16 months ago by ire

  • Resolution set to fixed
  • Status changed from new to closed

comment:13 Changed 16 months ago by sebastian

The share buttons are going to be completely remove (see #5613).

Note: See TracTickets for help on using tickets.