Opened 3 years ago

Closed 3 years ago

#4156 closed defect (fixed)

Removing the item from the advanced tab doesn't remove item in General tag

Reported by: saroyanm Assignee: saroyanm
Priority: P2 Milestone:
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29346555/

Description

Environment

Chrome: 51.0.2704.84

How to reproduce

  1. Navigate to advanced tab
  2. Remove Easylist from the drop down
  3. Navigate to General tab
  4. Observe

Observed behaviour

Easylist is still is not removed

Expected behaviour

Easylist is removed from the General tab as well

Change History (6)

comment:1 Changed 3 years ago by saroyanm

Please note that this issue doesn't only affect only deletion.
We currently checking if subscription is recommended in some places in the code, but we need to check if the "KnownFilter" is recommended or not, while added subscription item missing some info that we are keeping in "subscriptionsMap".
I'll suggest to update the subscriptin with the required information(properties from the "Knownsubscription") in "onSubscriptionMessage" because currently we are doing that not centralized probably one of the reasons why we missed this.

comment:2 Changed 3 years ago by greiner

  • Priority changed from Unknown to P2
  • Ready set

I was able to reproduce this issue.

comment:3 Changed 3 years ago by saroyanm

  • Owner set to saroyanm

comment:4 Changed 3 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 3 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.