Opened 17 months ago

Closed 9 months ago

#4164 closed defect (fixed)

Image displayed in new tab as well as overlaid in old tabs page

Reported by: scheer Assignee:
Priority: P3 Milestone: Adblock-Browser-for-iOS-1.5.2
Module: Adblock-Browser-for-iOS Keywords:
Cc: jand, mario, tomasnovella Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: no
Review URL(s):

Description

Having Imgur open in a tab and then opening an Imgur link from within that tab automatically opens a new tabbed window and loads the user into it, leaving the previous Imgur window in the background. The new tab is displayed correctly, but when the user returns to the original tab of which the link was clicked in, the open gif or image from the link is shown and blocks the page view. In most cases a 'Close' option is available in the top right of the screen to close the image or gif of which then returns the tab to its normal state.

Environment

ABB 1.4.0-qa (1036)
iPhone 6 Plus
ioS 9.3.1

How to reproduce

  1. Open imgur.com and select an image
  2. Scroll through the comments to find a link to another image or gif
  3. View the new open tab
  4. Open the tab view from the bottom right of the browser
  5. Select the previous Imgur tab


Observed behaviour

The newly opened image or gif is also displayed in the original tab as an overlay.

Expected behaviour

The original tab should either not have any overlay of the image or gif and only open the additional tab. Or, the overlay should be shown without any additional tabs being opened.

Attachments (1)

image1.PNG (477.7 KB) - added by scheer 9 months ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 17 months ago by pavelz

Observed: new tab should not be opened at all. Safari does not and all looks correct.

comment:2 Changed 17 months ago by mario

  • Priority changed from Unknown to P3
  • Ready set

comment:4 Changed 16 months ago by jand

I can fix the opening popup, but I do if I should fixed that black overlay. The problem is that this problem shares all browsers with UIWebView. So, I can dive deep into Javascript (probably I will have to ask some to help me with) and I can try to find why this page behave incorrectly. My question is if this is worth of effort?

comment:5 Changed 14 months ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 10 months ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Changed 9 months ago by scheer

comment:7 Changed 9 months ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Tester changed from Unknown to Scheer
  • When returning to the original tab, the black overlay is still displayed. Please see screenshot attached.

Current example:

  1. Visit http://imgur.com/gallery/Yk3bN
  2. Open comments and open link from comment http://i.imgur.com/ibcSrCU.gif
  3. Let tab load
  4. Return to original tab
Last edited 9 months ago by scheer (previous) (diff)

comment:8 Changed 9 months ago by pavelz

  • Cc jand added

The closing per https://issues.adblockplus.org/ticket/4164#comment:5 was unfortunately based on a wrong information about patch landing. The issue was not fixed yet. @jand will fix it ASAP.

Mind that there is two kinds of links in imgur comments. One is of form http://i.imgur.com/ibcSrCU.gif ("i" subdomain, "gif" extension) which does misbehave as described above (opens new tab, covers the original with black overlay). Other is of form http://imgur.com/LKDTIJG (no subdomain, no extension) which behaves equally correctly in Safari, Chrome, Firefox and ABB - it opens just new tab and makes no overlay. @jand make sure you are testing the first one.

comment:9 Changed 9 months ago by tomasnovella

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:10 Changed 9 months ago by mario

  • Cc mario added

comment:11 Changed 9 months ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened

The current behaviour is now that no new tab is opened and the gif is opened in the same window. Sadly, the gif is opened correctly, but a dark overlay is applied after a second or so.

To view this issue, please follow the steps as per described in comment 7, where step 3 is omitted.

ABB 1.5.2 (1451)
iPhone 6s
iOS 9.3.4

comment:12 Changed 9 months ago by tomasnovella

There were two (separate) problems in this issue.

  1. the opening of a unnecessary new tab
  2. black overlay
  1. The first one was caused by their unusual target=_blank handler, which is now fixed (and confirmed by Scheer)
  1. The second is an issue of webkit itself, more precisely a problem of UIWebView. That means, you run into same glitch if you use Opera or Mercury or any other iOS browser with a UIWebView.

Therefore I suggest the issue be closed since there's nothing we can do to remove the overlay.

comment:13 Changed 9 months ago by tomasnovella

  • Cc tomasnovella added
  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.