Opened 18 months ago

Last modified 14 months ago

#4165 reopened defect

Memory Pressure Crash after page scrolling on imgur.com

Reported by: scheer Assignee:
Priority: P2 Milestone:
Module: Adblock-Browser-for-iOS Keywords: cantfix
Cc: pavelz, mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

When the user scrolls quickly through particular pages without the content being fully loaded, ABB crashes. Upon restarting ABB, there is no option to send a crash report, which, after previous experience points towards a memory issue. Please see the JETSAM attached from the crashes.

Environment

ABB 1.4.0-qa (1036)
iPhone 6 Plus
iOS 9.3.1
ABP Enabled
AA Enabled
English Easylist
All 'more options' disabled

How to reproduce

  1. Visit http://imgur.com/gallery/vPzgT
  2. Before the page has fully loaded scroll quickly to the very bottom of page

OR

  1. If the page has loaded with 'Load 3 more images' then select this and scroll quickly to the bottom of the page

Observed behaviour

ABB crashes.

Expected behaviour

ABB should not crash.

Attachments (1)

JETSAM CRASH.txt (17.7 KB) - added by scheer 18 months ago.

Download all attachments as: .zip

Change History (9)

Changed 18 months ago by scheer

comment:1 Changed 18 months ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 1.4.0 qa build 1043 by merging chrome.storage fix from develop listed in https://issues.adblockplus.org/ticket/4012

comment:2 Changed 18 months ago by pavelz

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:3 Changed 18 months ago by pavelz

Sorry wrong resolution. Mixed up with 4166.
But anyway @scheer, i can't reproduce. Step 2. does not take me very far as the page is quite short initially and it reflows only when there are the comments. Then it's pretty much complete so nothing else is loading. Step 3. i don't see any "Load 3 more images" action. I'm not proficient with imgur, sorry :)

comment:4 Changed 18 months ago by scheer

  • Summary changed from Memory Pressure Crash to Memory Pressure Crash after page scrolling on imgur.com

comment:5 Changed 18 months ago by scheer

@pavelz the 'load 3 more images' occurs when the page has not yet had time to load fully and there are more images to display. Sometimes this happens when you scroll too fast, sometimes it bypasses this and just loads the images straight away. Try some other articles on imgur.com that have a slightly larger page length (or image content). This, however, still occurs on the link given on the iPhone 6 Plus, iOS 9.3.1 for me.

As for step 2, loading fast or not, this still occurred for me in the given article. As soon as you select the link and the first image is loaded, 'flick' the screen up (to scroll down) and continue to do so until you reach the bottom of the page. Just so we are clear here - users would have this behaviour if they had already been to the post and wanted to see the last image again, the comments again etc. Users may also perform this behaviour if they simply wanted to read the comments without looking at the article.

comment:6 Changed 18 months ago by mario

  • Cc pavelz mario added

comment:7 Changed 18 months ago by mario

  • Priority changed from Unknown to P2
  • Ready set

comment:8 Changed 14 months ago by pavelz

  • Keywords cantfix added
Note: See TracTickets for help on using tickets.