Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4170 closed defect (worksforme)

Element hiding exception rules don't work

Reported by: arthur Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, mapx Blocked By:
Blocking: #4139 Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Firefox 48 Beta 1
ABP 2.7.3.4184
Windows 10 Pro

How to reproduce

  1. Add adblockplus.org###main and adblockplus.org#@##main to ABP
  2. Go to https://adblockplus.org/

Observed behaviour

<section id="main"> is hidden.

Expected behaviour

<section id="main"> shouldn't be hidden because of the element hiding exception rule.

Change History (6)

comment:1 Changed 3 years ago by mapx

  • Cc mapx added

comment:2 Changed 3 years ago by trev

  • Blocking 4139 added

I'm pretty sure that this has the same root cause as the memory leak I noted in #4139. As #4139 has been fixed again, please retest in ABP 2.7.3.4185 that will be available in approximately 15 minutes.

comment:3 follow-up: Changed 3 years ago by arthur

Seems to be working on 47.0.1 but on 48 Beta 4 (enforced e10s via about:config pref) and Nightly it seems element hiding seems broken at least in the first browser window. I don't have enough time to properly test it right now though.

comment:4 Changed 3 years ago by trev

  • Resolution set to worksforme
  • Status changed from new to closed

The issue reported here is not reproducible any more with Adblock Plus 2.7.3.4185 development build.

I'll try to reproduce the other issue but it's clearly unrelated.

comment:5 Changed 3 years ago by trev

Note that #521 is being pushed now and it will change element hiding behavior once again.

comment:6 in reply to: ↑ 3 Changed 3 years ago by arthur

Replying to arthur:

Seems to be working on 47.0.1 but on 48 Beta 4 (enforced e10s via about:config pref) and Nightly it seems element hiding seems broken at least in the first browser window.

I no longer have this issue with 2.7.3.4185.

Note: See TracTickets for help on using tickets.