Opened 3 years ago

Closed 3 years ago

#4175 closed defect (fixed)

Credit Card donations page displays the wrong product name for Russian and Chinese

Reported by: Shikitita Assignee:
Priority: P3 Milestone:
Module: Websites Keywords:
Cc: saroyanm, juliandoucette, fhd Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by Shikitita)

Environment

Platform: PC
Browser: Any
Version: Any

How to reproduce

  1. Access https://adblockplus.org/en/donate
  2. Change the language into Russian or Chinese by clicking on the flag at the top right of the website
  3. Select the option next to PayPal and choose the currency and amount of money desired
  4. Click on the green button

Observed behaviour

The name of the product in the "credit-card.micropayment.de" website is not displayed properly as can be seen on the attached screenshot

Expected behaviour

Text should read properly as per the translations given for each language

Attachments (1)

Donations_abp.org.jpg (105.3 KB) - added by Shikitita 3 years ago.

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Shikitita

comment:1 Changed 3 years ago by Shikitita

  • Description modified (diff)

comment:2 Changed 3 years ago by juliandoucette

  • Cc fhd added
  • Priority changed from Unknown to P2

@fhd looks like a micropayments.de configuration problem or defect. Can you (or who else?) investigate?

comment:3 Changed 3 years ago by saroyanm

  • Priority changed from P2 to P3
  • Ready set

I think the priority for this issue is not that urgent, because this issue existed for a really long time and nobody yet complained, also we had similar issues that was marked P3(#219, #1683), so I think marking this issue P3 is more reasonable, we probably have more important prio issues that are P2

comment:4 Changed 3 years ago by philll

The integration with micropayment was invented by #1477 and the item name is handed over as "paytext" field, filled with the i18n_name of our form. When we hand over the russian string in the URL like in this example, we end up with the characters unrecognized. Chinese locality seems completely unsupported however. We might want to hand over the English string instead. For a list of supported languages, see the "countryLanguage" field in the micropayment form. I couldn't get the russian text over correctly with or without URL encoding, so I guess it's an issue on their end. I'll talk to them.

comment:5 Changed 3 years ago by philll

Micropayment's help desk wrote that they figured out somewhat more extensive encoding issues which they now have to investigate. We'll get notified once they got it fixed.

comment:6 Changed 3 years ago by philll

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed by micropayment and seems to work fine now.

Note: See TracTickets for help on using tickets.