Opened 3 years ago

Closed 13 months ago

#4176 closed change (rejected)

Create FilterEngineTest.testFilterProperties test

Reported by: asmirnov Assignee: asmirnov
Priority: P3 Milestone:
Module: Libadblockplus-Android Keywords:
Cc: rjeschke Blocked By:
Blocking: #4031 Platform: Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Due to missing Filter.setProperty() it's impossible to do the test similar to https://hg.adblockplus.org/libadblockplus/file/tip/test/FilterEngine.cpp#l129.

smth like

@Test
    public void testFilterProperties()
    {
        Filter filter = filterEngine.getFilter("foo");

        assertTrue(filter.getProperty("stringFoo").isUndefined());
        assertTrue(filter.getProperty("intFoo").isUndefined());
        assertTrue(filter.getProperty("boolFoo").isUndefined());

        // TODO : since there is no setProperty for Filter finish the test later
    }

Change History (1)

comment:1 Changed 13 months ago by asmirnov

  • Resolution set to rejected
  • Status changed from new to closed

The tests are rewritten, the issue is deprecated.

Note: See TracTickets for help on using tickets.