Opened 3 years ago

Closed 13 months ago

#4177 closed change (rejected)

Create FilterEngineTest.testSubscriptionProperties test

Reported by: asmirnov Assignee: asmirnov
Priority: P3 Milestone:
Module: Libadblockplus-Android Keywords:
Cc: rjeschke Blocked By:
Blocking: #4031 Platform: Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Due to missing Subscription.setProperty() it's impossible to do the test similar to ​https://hg.adblockplus.org/libadblockplus/file/tip/test/FilterEngine.cpp#l167.

smth like

@Test
    public void testSubscriptionProperties()
    {
        Subscription subscription = filterEngine.getSubscription("foo");

        assertTrue(subscription.getProperty("stringFoo").isUndefined());
        assertTrue(subscription.getProperty("intFoo").isUndefined());
        assertTrue(subscription.getProperty("boolFoo").isUndefined());

        // TODO : since there is no setProperty finish the test later
    }

Change History (3)

comment:1 Changed 3 years ago by asmirnov

  • Ready set

comment:2 Changed 3 years ago by asmirnov

  • Platform changed from Unknown / Cross platform to Android

comment:3 Changed 13 months ago by asmirnov

  • Resolution set to rejected
  • Status changed from new to closed

The tests are rewritten, the issue is deprecated.

Note: See TracTickets for help on using tickets.