Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#418 closed defect (incomplete)

Adblock Plus starts up delayed meaning that the first page to load might have ads

Reported by: jimec Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@…, trev Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Windows 7 Home Premium Service Pack 1 64bit
Firefox 29.0
Adblock Plus 2.6
EasyList
Element Hiding Helper 1.3

How to reproduce

  1. Click on Firefox icon on Taskbar
  2. Wait

Observed behaviour

Firefox loads and opens to my homepage (yahoo mail). My homepage is flooded with ads. After waiting 15 to 30 seconds, Adblock Plus loads and the ads disappear.

Expected behaviour

I expect ABP to load with Firefox and stop the ads from loading onto my homepage. I DO NOT expect to sit and stare at ads for an extended period while waiting for ABP to block them so I can continue.

Change History (13)

comment:1 Changed 5 years ago by mapx

  • Cc smultron45@… added

comment:2 follow-up: Changed 5 years ago by trev

  • Cc trev added
  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid - loading filters takes time and delaying Firefox startup by that time would certainly be worse. Which doesn't mean that we shouldn't speed up things, that's subject of #145 for example.

For reference, the change to asynchronous loading was made years ago. However, we now fixed issues that still caused us block Firefox load process: #117 and #153.

Last edited 5 years ago by trev (previous) (diff)

comment:3 Changed 5 years ago by jimec

The difference in waiting for Firefox to load and waiting for ABP to load is that the way it is now, I have to watch my screen fill up with ads while I'm waiting. Timewise, there is no advantage to the current situation. Adwise, there is a clear disadvantage.

comment:4 Changed 5 years ago by trev

  • Summary changed from ABP Very Slow Loading to Adblock Plus starts up delayed meaning that the first page to load might have ads

comment:5 in reply to: ↑ 2 Changed 5 years ago by sabret00the

Replying to trev:

Closing as invalid - loading filters takes time and delaying Firefox startup by that time would certainly be worse. Which doesn't mean that we shouldn't speed up things, that's subject of #145 for example.

For reference, the change to asynchronous loading was made years ago. However, we now fixed issues that still caused us block Firefox load process: #117 and #153.

Could an option not be provided that would allow users to decide whether it's more important to them to have a quick loading Firefox or to have their privacy remain intact?

comment:6 Changed 5 years ago by hajj_3

i have 40 tabs that restore when i launch firefox now 15 or so tabs have ads on that i have to reload to get rid of. This takes me 20 seconds yet i save just 1 second on startup and i lose my privacy. The whole purpose of adblock is to block ads, this change does the exact opposite. Disable this stupid "feature" by default and let people optionally enable it if they want to.

comment:7 Changed 5 years ago by Trevor

+1
This needs to be fixed one way or another. And fast please :/

I am having ads every time i open up a link from my desktop/link folder (not going to use build in "bookmarks" function)

Having ads show up, and then quickly disappear is NOT okay. That's the whole purpose of ABP thrown out the window along with users privacy. everything needs to be blocked BEFORE it gets a chance to load. everything else is just a failure.

The purpose of APB is to block this stuff. Now it is failing to do so.
Thus, this should be considered a fatal bug.

If you have not seen it already. Here is a 4 page discussion about the issue people are having.
https://adblockplus.org/forum/viewtopic.php?f=1&t=22906

comment:8 Changed 5 years ago by Crits

Issue reports are also quickly becoming clogged by reports of people who see ads on their start page.
That's a huge loss of time for list authors as they have to spend time analyzing numerous useless reports (it's not that obvious that ads are appearing because of issue #418), just to see at the end that filter lists are not the problem there.

Version 0, edited 5 years ago by Crits (next)

comment:9 follow-up: Changed 5 years ago by richwest

Please reconsider this decision. It negatively impacts my experience, and it's clear from the forum thread (as Trevor linked) that many others feel the same way. Blocking adverts reliably should be priority #1, I've never had an issue with startup time.

A better way for ABP users to offer feedback to the developers would also be nice. It's rather ridiculous that a bunch of users sign up for forum accounts to give feedback on this issue, only for a moderator to imply that there's little chance of a developer responding on the forums and pointing us here instead. Is a closed ticket really the best place to offer feedback? Surely a better system would be for a developer to read the forums, or to put a system in place where the moderators can bring widespread issues to the deveopers' attention.

Last edited 5 years ago by richwest (previous) (diff)

comment:10 Changed 5 years ago by philll

Some temporary information approach: #472

comment:11 in reply to: ↑ 9 Changed 5 years ago by Crits

Replying to richwest:

[...] or to put a system in place where the moderators can bring widespread issues to the deveopers' attention.

Well, that's the role of issues.adblockplus.org

comment:12 Changed 5 years ago by orion44

Hi Trev - this is a defect and not an enhancement. Please do the right thing and reopen this ticket and correct the problem. Thanks!

comment:13 Changed 5 years ago by philll

See #549

Note: See TracTickets for help on using tickets.