Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#4190 closed defect (fixed)

No filter list is active on first run

Reported by: diegocarloslima Assignee: diegocarloslima
Priority: P2 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: rjeschke Blocked By: #4278
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Description

On first run, no filter list is active by default

How to reproduce

  1. Run the app and tap the overflow menu (top right)
  2. Tap on Settings
  3. Tap on Ad blocking
  4. Tap on Ad blocking

Observed behaviour

No filter list is active (checked)

Expected behaviour

On first run, the English EasyList should be active by default

Change History (7)

comment:1 Changed 3 years ago by diegocarloslima

  • Owner set to diegocarloslima

comment:2 Changed 3 years ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 3 years ago by fhd

  • Cc rjeschke added

Given how the fix for this (and supposedly #3389) is nothing but a dependency update - can we please create a proper dependency update issue that lists the changes that have happened in ABP since the last version? (Please ask Mario if unsure about how exactly those issues work).

Then we can mark this issue (and #3389) as blocked by the dependency update, and just close them as fixed when the dependency update has landed.

comment:4 Changed 3 years ago by diegocarloslima

  • Blocked By 4278 added
  • Review URL(s) modified (diff)
  • Status changed from reviewing to reopened

comment:5 Changed 3 years ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed by #4278

comment:6 Changed 3 years ago by fhd

  • Milestone set to Adblock-Browser-for-Android-next

comment:7 Changed 2 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • On first run, Easylist is active by default.

ABB adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

Note: See TracTickets for help on using tickets.