Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4192 closed defect (fixed)

Build fails when using git repository

Reported by: greiner Assignee: kzar
Priority: P1 Milestone:
Module: Automation Keywords:
Cc: sebastian, kzar, kvas, trev Blocked By:
Blocking: #4197, #4208, #4490 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29347006/

Description

Environment

Ubuntu 14.04

How to reproduce

git clone https://github.com/adblockplus/adblockpluschrome
cd adblockpluschrome
python build.py -t chrome build

Observed behaviour

Build not created due to the following error:

Traceback (most recent call last):
  File "./build.py", line 18, in <module>
    buildtools.build.processArgs(BASE_DIR, sys.argv)
  File "/home/thomas/tmp/adblockpluschrome/buildtools/build.py", line 613, in processArgs
    commands[command](baseDir, scriptName, opts, args, type)
  File "/home/thomas/tmp/adblockpluschrome/buildtools/build.py", line 55, in __call__
    return self._handler(baseDir, scriptName, opts, args, type)
  File "/home/thomas/tmp/adblockpluschrome/buildtools/build.py", line 207, in runBuild
    releaseBuild=releaseBuild, keyFile=keyFile)
  File "/home/thomas/tmp/adblockpluschrome/buildtools/packagerChrome.py", line 326, in createBuild
    version = getBuildVersion(baseDir, metadata, releaseBuild, buildNum)
  File "/home/thomas/tmp/adblockpluschrome/buildtools/packager.py", line 60, in getBuildVersion
    if len(buildNum) > 0:
TypeError: object of type 'int' has no len()

Note that this doesn't occur when using the Mercurial repository.

Expected behaviour

Build created without errors.

Change History (9)

comment:1 Changed 3 years ago by kzar

  • Cc kvas trev added
  • Component changed from Unknown to Build-and-Release-Tools
  • Priority changed from Unknown to P1
  • Ready set

Can reproduce, seems to be a regression caused by Issue 4099 - Don't enforce Gecko build IDs to be numerical.

comment:2 Changed 3 years ago by kzar

  • Owner set to kzar

comment:3 Changed 3 years ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4192 - getBuildNum must return a string

comment:5 Changed 3 years ago by kzar

  • Review URL(s) modified (diff)

comment:6 Changed 3 years ago by kzar

  • Blocking 4197 added

comment:7 Changed 3 years ago by kzar

  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from reviewing to closed

(Just remembered I'm supposed to dependency updates in a separate issue, so moved that over to #4197.)

comment:8 Changed 3 years ago by kzar

  • Blocking 4208 added

comment:9 Changed 3 years ago by kzar

  • Blocking 4490 added
Note: See TracTickets for help on using tickets.