Opened 17 months ago

Closed 5 months ago

#4194 closed defect (fixed)

Failed to compile libadblockplus for ARM on mac

Reported by: asmirnov Assignee:
Priority: P2 Milestone:
Module: Libadblockplus Keywords:
Cc: sergz, rjeschke Blocked By: #4907
Blocking: #4188 Platform: Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

I was able to compile libadblockplus for android (both arm and x86) on linux (ubuntu 16.04).
Also i was able to compile it for x86 on mac, but i failed to compile it for arm.

Attaching make android_arm -j8 V=1 &> build_arm.log logfile.

env:


android-ndk-10c

MBA-Anton:libadblockplus.1 asmirnov$ clang --version
Apple LLVM version 7.3.0 (clang-703.0.29)
Target: x86_64-apple-darwin15.4.0
Thread model: posix
InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

osx el capitan 10.11.4

Attachments (1)

build_arm.log.zip (131.2 KB) - added by asmirnov 17 months ago.

Download all attachments as: .zip

Change History (6)

Changed 17 months ago by asmirnov

comment:1 Changed 17 months ago by asmirnov

  • Blocking 4188 added
  • Ready set

comment:2 Changed 14 months ago by fhd

Yup, I can easily reproduce this on OS X 10.11.6 with LLVM/Clang 8.0.0.

From a very quick glance, this looks like an issue with compiling v8, not any of our code.

comment:3 Changed 14 months ago by sergz

This issue has appeared after some update of osx. It seems to be an issue with mksnapshot. Since, it works flawlessly on linux, I would rather firstly update v8 (#1197) and then address this issue if it still exist.

If it helps, I can easily provide with e.g. dockerfile with linux, so one can easily obtain libadblockplus binaries.

comment:4 Changed 6 months ago by sergz

  • Blocked By 4907 added

It will be fixed with updating of v8.

comment:5 Changed 5 months ago by sergz

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with new V8.

Note: See TracTickets for help on using tickets.