Opened 3 years ago

Closed 3 years ago

#4196 closed defect (duplicate)

Adblock Plus no longer blocks ads on YouTube

Reported by: mkikoen Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

21.5 inch iMac 4K with Retina Display, OSX El Capitan version 10.11.5, Safari version 9.1.1, Adblock Plus version 1.12. Adblock Plus Filters: Easylist, Adblock Plus Warning Removal List

How to reproduce

  1. Use the latest Safari browser version and Adblock Plus version 1.12 for Safari


  1. Go to www.youtube.com
  1. Make sure you have non-intrusive ads unchecked, safari's native Content Blocking unchecked, and that you at least have the EasyList filter.
  1. Watch this example video on youtube and wait until you the stupid ads show up

... https://www.youtube.com/watch?v=AfZ-DOCc3AE

Observed behaviour

Every time I try to watch YouTube videos, the stupid annoying ads are now completely unblocked, and the experiment safari's native content blocking feature is useless because it doesn't always block all the ads whenever I refresh, plus it slows down the performance and the loading time of the YouTube Player so I never use it.

Expected behaviour

I expect ads to always be blocked completely on YouTube because yes I do have Non-Intrusive advertising unchecked & YouTube is not whitelisted, but even if I have Safari's native Content Blocking feature turned on or off, when it's on it doesn't always block the ads and it's slow so I never use it, when it's off Adblock Plus never blocks any ads because this is unacceptable. This needs to be fixed ASAP because this has never happened to me before.

Attachments (2)

Screen Shot 2016-06-24 at 5.05.27 PM.png (2.9 MB) - added by mkikoen 3 years ago.
YouTube ads unblocked.
Screen Shot 2016-06-24 at 5.25.23 PM.png (107.0 KB) - added by mkikoen 3 years ago.
log in Error Console regarding unable to load ads on YouTube

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by mkikoen

YouTube ads unblocked.

comment:1 Changed 3 years ago by mkikoen

Okay, for some reason, about 3+ minutes ago, as I continue to refresh the page of the same video I'm looking at, now the ads are getting blocked, even though I see absolutely no recent updates in the Safari Development Build Changelog specifically for today June 24, 2016. I don't know what's going on, I'll watch other YouTube videos to see if the ads on those are not getting blocked.

P.S. I don't know if this'll help or not but here's a few of the filters that was added when I tried to block the ad element on YouTube.

youtube.com##video[src="blob:https://www.youtube.com/7ada8e7a-5df4-49f9-a887-49e8291b3b03"]

launch.newsinc.com/118/js/lib/amp.premier/AkamaiPremierPlayer.swf

comment:2 Changed 3 years ago by mkikoen

Here's something reported in the Safari Error Console, I don't know if this has to do with the filters from my previous post or not but if it helps you guys with fixing the ads not being blocked on YouTube then be sure to reference this picture. Sometimes when I watch some YouTube videos, the video doesn't load and becomes a black screen but the audio does load, so then I refresh it and then it works, I'm thinking that might have something to do with the filters mentioned in my previous post so moderators & developers, please review my Issue ticket of #4196 and all of my attachments and posts ASAP because I'm still not confident to confirm that now all of a sudden the ads are gone now.

Changed 3 years ago by mkikoen

log in Error Console regarding unable to load ads on YouTube

comment:4 Changed 3 years ago by mapx

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.