Opened 3 years ago

Closed 8 weeks ago

#4215 closed defect (rejected)

$generichide is blocking specific elements

Reported by: fanboy Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: mapx, kzar Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Using Firefox nightly and ABP-Dev 2.7.3.4187 on Windows x64.

How to reproduce

  1. Subscribe to Easylist and Annoyances list
  2. Visit an article on http://www.dailymail.co.uk
  3. Shows all social/Annoyances elements
  4. Disable Easylist, and the specific elements will be blocked.

Observed behaviour

$generichide seems to be disallowing specific elements from executing.

Expected behaviour

$generichide shouldn't.

Change History (6)

comment:1 Changed 3 years ago by mapx

  • Cc mapx trev added

comment:2 Changed 3 years ago by mapx

it seems like $generichide is acting like $elemhide (I can not create any hiding filter to hide the space at the top - under the title)

Last edited 3 years ago by mapx (previous) (diff)

comment:3 in reply to: ↑ description Changed 3 years ago by trev

Replying to fanboy:

$generichide seems to be disallowing specific elements from executing.

Could you explain in some more detail what you see? When I open blockable items I can only see one element hiding filter from Social Blocking active: dailymail.co.uk##.dms-puff. This is in fact a specific filter, applying specifically to the Daily Mail website. Are you seeing something different? Are you expecting something different?

comment:4 Changed 22 months ago by fhd

  • Cc trev removed

comment:5 Changed 22 months ago by kzar

  • Cc kzar added
  • Component changed from Unknown to Platform

comment:6 Changed 8 weeks ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.