Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4216 closed defect (fixed)

[HA Crash] Receiving response headers

Reported by: jand Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.5.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by jand)

https://rink.hockeyapp.net/manage/apps/310687/app_versions/23/crash_reasons/126836457
https://rink.hockeyapp.net/manage/apps/310687/app_versions/23/crash_reasons/126753117

Probably related:
https://rink.hockeyapp.net/manage/apps/310687/app_versions/23/crash_reasons/126701916
https://rink.hockeyapp.net/manage/apps/310687/app_versions/23/crash_reasons/126804760
https://rink.hockeyapp.net/manage/apps/310687/app_versions/23/crash_reasons/126779846

Environment

Adblock Browser 1.4.0 (Appstore)

How to reproduce

Reproduction unknown

Observed behaviour

Only hockeyapp crash report.
The problem is probably caused by casting NSDictionary (as allHeaderFields of NSURLHTTPResponse) to swift [String: String] type. allHeaderFields might be containing string nonconvertible type.

Change History (12)

comment:1 Changed 3 years ago by jand

  • Component changed from Unknown to Adblock-Browser-for-iOS

comment:2 Changed 3 years ago by jand

  • Platform changed from Unknown / Cross platform to Adblock Browser for iOS

comment:4 Changed 3 years ago by jand

  • Description modified (diff)

comment:5 Changed 3 years ago by jand

  • Description modified (diff)

comment:6 Changed 3 years ago by jand

Last edited 3 years ago by jand (previous) (diff)

comment:7 Changed 3 years ago by jand

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 3 years ago by jand

  • Description modified (diff)

comment:9 Changed 3 years ago by jand

  • Description modified (diff)

comment:10 Changed 3 years ago by pavelz

  • Priority changed from Unknown to P1

comment:11 Changed 3 years ago by pavelz

  • Ready set

comment:12 Changed 3 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Batch modify: set correct milestone

Note: See TracTickets for help on using tickets.