Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4222 closed defect (fixed)

[HA crash] iOS8 crash when removing an actively loading tab

Reported by: pavelz Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.5.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Environment

Adblock Browser 1.4.0 (AppStore)

How to reproduce

Reproduction unknown. Probably loading a slow webpage and trying to slide-remove it in the tab view very fast

Observed behaviour

https://rink.hockeyapp.net/manage/apps/310687/app_versions/23/crash_reasons/126735100
https://rink.hockeyapp.net/manage/apps/310687/app_versions/23/crash_reasons/126712172

Expected behaviour

Does not crash

Change History (5)

comment:2 Changed 3 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 3 years ago by pavelz

  • Ready set

comment:4 Changed 3 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Batch modify: set correct milestone

comment:5 Changed 3 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

As there is no reproduction to this, I simply tried the suggested 'Probably loading a slow web page and trying to slide-remove it in the tab view very fast'.

With the above mentioned, I was not able to reproduce this issue.

Using the stats page on the Hockey App issues mentioned in this ticket, I narrowed this issue down to the iPhone 6 and iPhone 5S with iOS 8.3 to be the worst affected. I used these devices to test with.

ABB 1.5.0 (1060)
iPad Air 2
iOS 8.4

ABB 1.5.0 (1060)
iPhone 6
iOS 8.3

ABB 1.5.0 (1060)
iPhone 5S
iOS 8.3

Note: See TracTickets for help on using tickets.