Opened 3 years ago

Closed 3 years ago

#4228 closed defect (duplicate)

Fix the most prominent crash reports from ABB 1.4.0

Reported by: mario Assignee:
Priority: P1 Milestone:
Module: Adblock-Browser-for-iOS Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mario)

Environment

Adblock Browser 1.4.0
Any iOS version
Any device

Background

After releasing ABB 1.4.0 we've accumulated a list of stack traces of the most prominent crash reports.

Want to fix

Fix all bugs indicated by the following stack traces:

  • Stack Trace for function signature specialization <Arg[ 0] = Owned To Guaranteed> of KittCore... (63 crashes*)
  • Stack Trace for function signature specialization <Arg[ 0] = Owned To Guaranteed, Arg[ 1] = Owned... (56 crashes*)
  • Stack Trace for - [WebRequestEventDispatcher onHeadersReceived:withDetails:responseBlock:] (24 crashes*)
  • Stack Trace for - [ConnectionAuthenticator authenticateChallenge:resultHandler:] (18 crashes*)
  • Stack Trace for function signature specialization <Arg[ 0] = Owned To Guaranteed> of KittCore... (16 crashes*)
  • Stack Trace for - [WebRequestEventDispatcher onHeadersReceived:withDetails:responseBlock:] (16 crashes*)
  • Stack Trace for - [ConnectionAuthenticator authenticateChallenge:resultHandler:] (15 crashes*)
  • Stack Trace for - [WebRequestEventDispatcher onHeadersReceived:withDetails:responseBlock:] (11 crashes*)
  • Stack Trace for generic specialization <KittCore.ChromeTab> of Swift._ArrayBuffer._getElementSlowPath... (8 crashes*)
  • Stack Trace for function signature specialization <Arg[ 0] = Owned To Guaranteed, Arg[ 1] = Owned To... (5 crashes*)

*as of 2016-07-05, 3 p.m.

Remark for testers

Please note that we only know the sources of the described crashes, as we can only rely on stack traces provided by the crash reports. We do not know how the crashes can be manually triggered and thus there's no way to reliably reproduce them.
The only way to verify that those bugs are fixed, is by monitoring the crash reports for upcoming development builds/release builds and compare them to the attached stack traces.

Attachments (10)

crash_report_1.txt (2.1 KB) - added by mario 3 years ago.
crash_report_2.txt (532 bytes) - added by mario 3 years ago.
crash_report_3.txt (862 bytes) - added by mario 3 years ago.
crash_report_4.txt (1.5 KB) - added by mario 3 years ago.
crash_report_5.txt (416 bytes) - added by mario 3 years ago.
crash_report_6.txt (653 bytes) - added by mario 3 years ago.
crash_report_7.txt (407 bytes) - added by mario 3 years ago.
crash_report_8.txt (653 bytes) - added by mario 3 years ago.
crash_report_9.txt (897 bytes) - added by mario 3 years ago.
crash_report_10.txt (533 bytes) - added by mario 3 years ago.

Download all attachments as: .zip

Change History (12)

Changed 3 years ago by mario

Changed 3 years ago by mario

Changed 3 years ago by mario

Changed 3 years ago by mario

Changed 3 years ago by mario

Changed 3 years ago by mario

Changed 3 years ago by mario

Changed 3 years ago by mario

Changed 3 years ago by mario

Changed 3 years ago by mario

comment:1 Changed 3 years ago by mario

  • Description modified (diff)

comment:2 Changed 3 years ago by mario

  • Milestone Adblock-Browser-for-iOS-next deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4216, #4219, #4220, #4222

Note: See TracTickets for help on using tickets.