Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4230 closed defect (fixed)

$generichide is apparently whitelisting site-specific hiding filters as well

Reported by: arthur Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.8-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29347299/

Description

Environment

Windows 10 Pro
Firefox 47.0, 48.0 Beta 5 and Nightly (20160706030233)
ABP 2.7.3.4189

How to reproduce

  1. Add this custom filter adblockplus.org###main
  2. Go to https://adblockplus.org/
  3. Notice the missing content
  4. Add this custom exception rule @@||adblockplus.org^$generichide
  5. Go to https://adblockplus.org/

Observed behaviour

Missing content is back, adblockplus.org###main seems to be whitelisted by @@||adblockplus.org^$generichide.

Expected behaviour

Since adblockplus.org###main is a site-specific filter, it should still hide the DIV.

Change History (5)

comment:1 Changed 3 years ago by trev

  • Owner set to trev
  • Ready set

comment:2 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 3 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Priority changed from Unknown to P1
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 2.7.3.4214-beta
Firefox 38 / 46 / 49 / Windows 7
Firefox Nightly 52.0a1 (2016-10-20) / Windows 7

Note: See TracTickets for help on using tickets.