Opened 3 years ago

Closed 3 years ago

#4235 closed defect (duplicate)

Better Anti-adblock switches options.

Reported by: fanboy Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: trev, arthur, sebastian, kzar, greiner, mapx Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Not sure if there page for this, but we need more ways to counter Anti-adblock methods. Because as it stands we're getting steamrolled by many Anti-adblock scripts being rolled out and we cant do a lot to counter it. Without action users will look else where for their Adblock options.

$redirect:

Ability to stop page redirects (either 1st party or 3rd party sites)

  • So if a user clicks on a link, it doesn't re-direct user to ad. (as seen on pornhub)
  • Or force the user onto another page because they had Adblock Plus enabled. (as seen recently on ndtv com or timesofindia.indiatimes com)


$inline-script in ublockOrigin would be helpful also, which would counter embedded Anti-adblock scripts on the site.

Make $genericblock work better would helpful here; https://issues.adblockplus.org/ticket/4204

Change History (2)

comment:1 Changed 3 years ago by mapx

  • Cc trev arthur sebastian kzar greiner mapx added

comment:2 Changed 3 years ago by kzar

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this issue as it seems to be a duplicate of several other issues:

  • Changing the $genericblock behaviour has already been requested in #4204.
  • Your suggestion for $redirect seems to be the same as $popunder as requested in #2095.
  • The $inline-script suggestion already exists as #3207.
Note: See TracTickets for help on using tickets.