Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#424 closed defect (fixed)

Adblock Warning Removal List disabling itself

Reported by: Crits Assignee: greiner
Priority: P1 Milestone: Adblock-Plus-2.6.1-for-Firefox
Module: Core Keywords:
Cc: trev Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5198627827875840/
http://codereview.adblockplus.org/6324527734718464/

Description (last modified by greiner)

Environment

Windows 7 SP1 x64
Firefox 29.0
Adblock Plus 2.6.0.3805

How to reproduce

  1. Have the Adblock Warning Removal List activated
  2. Update ABP

Observed behaviour

The Adblock Warning Removal List is no longer active.
At least one other user is experiencing that: https://adblockplus.org/forum/viewtopic.php?t=22528

Expected behaviour

The list should be kept activated.

Change History (9)

comment:1 Changed 6 years ago by mikhaelkh

It happens after ABP update.

comment:2 Changed 6 years ago by philll

  • Priority changed from Unknown to P1
  • Ready set

comment:3 Changed 6 years ago by philll

  • Description modified (diff)

comment:4 Changed 6 years ago by greiner

  • Component changed from Adblock-Plus-for-Firefox to Core
  • Description modified (diff)
  • Owner set to greiner

I was able to reproduce this on Chrome as well due to it being caused by shared logic.

Last edited 6 years ago by greiner (previous) (diff)

comment:5 Changed 6 years ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 6 years ago by trev

  • Cc trev added

comment:7 Changed 6 years ago by greiner

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 6 years ago by Crits

Wow, that was fast!

comment:9 Changed 6 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
Note: See TracTickets for help on using tickets.