Opened 3 years ago

Closed 3 years ago

#4242 closed defect (worksforme)

Element hiding exception rule not always working as expected when refreshing page

Reported by: arthur Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 10 Pro
Firefox 47.0.1
ABP 2.7.3.4191

How to reproduce

  1. Update all filters in ABP
  2. Go to http://cmdrkeene.com/windows-desktop-topology (has been whitelisted recently)

Observed behaviour

The top ad frame (responsive) isn't appearing on every refresh (note that only sometimes you will see a text ad, display ads stay blocked). Once you disable ##.adsbygoogle in EasyList, it will appear everytime.

I expected this to be fixed by #521 but it seems to be a different issue after all. But it seems that it's working properly now when ABP is disabled for a specific domain only.

Expected behaviour

It should appear on every refresh since ##.adsbygoogle is whitelisted for cmdrkeene.com.

Change History (3)

comment:1 Changed 3 years ago by trev

If this is an XBL timing issue then it should be fixed by #524, not #521. Until #524 lands we still have exceptions handled via XBL bindings, only then we will have no CSS rules apply to elements with exceptions.

comment:2 Changed 3 years ago by trev

Never mind, I realized that element hiding is completely disabled on that site - then with #521 element hiding indeed shouldn't have any effect on this site. But at least in Firefox 50.0a1 nightly I can completely disable our element hiding functionality (don't load the corresponding module at all), this particular ad still fails to show up occasionally. If I'm not entirely mistaken, this issue is due to the website scripts in combination with our blocking, not related to element hiding.

comment:3 Changed 3 years ago by trev

  • Resolution set to worksforme
  • Status changed from new to closed

Same thing on Firefox 47.0.1 - this isn't related to our element hiding handling. If I understand correctly, they show a fallback ad if their main ad is blocked. I bet that the code they use for that has a timing issue.

Note: See TracTickets for help on using tickets.