Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4265 closed defect (fixed)

Adblock Plus 0.9.5.0 hangs apps.facebook.com

Reported by: scottlow Assignee: oleksandr
Priority: Unknown Milestone: Adblock-Plus-0.9.8-for-Microsoft-Edge
Module: Unknown Keywords:
Cc: trev, oleksandr, sebastian Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29352610/

Description

Environment

Adblock Plus 0.9.5.0
Microsoft Edge
Windows 10 Insider Build

How to reproduce

  1. Install Adblock Plus 0.9.5.0 for Edge
  2. Navigate to https://apps.facebook.com/wordswithfriends/tracks.php?src=community&aff=fanpage&crt=playnow
  3. Try to interact with the game

...

Observed behaviour

The tab hangs

Expected behaviour

The tab does not hang

Change History (13)

comment:1 Changed 3 years ago by trev

Just to make sure we are on the same page, I tried to reproduce with Microsoft Edge 38.14393.0.0 - this should be the latest version. I logged into Facebook, granted the game the necessary permissions. While I have fairly little idea about how to play this game, the tab clearly doesn't hang. I also tried loading the page again, this time without having to grant permissions - same thing.

This report is probably missing important details. Does any of the above seem different from what you've been doing? Does "try to interact with the game" mean something in particular?

comment:2 Changed 3 years ago by trev

  • Cc trev added

comment:3 Changed 3 years ago by oleksandr

  • Cc oleksandr added

comment:4 Changed 3 years ago by scottlow

Sorry for the delay on the reply here. I was able to repro this today on the latest Windows Insider Preview build by navigating to that link with ABP 0.9.6.0 installed. The game loads, but clicking and dragging one of the letter tiles froze the game and eventually caused the tab to crash. Are you able to repro this behavior?

comment:5 Changed 3 years ago by oleksandr

I have just now reproduced it. The issue seems to be occurring when the ad on the bottom is rotated. We will look into this, thanks!

comment:6 Changed 3 years ago by scottlow

I looked into this issue on the Edge side and determined that it is caused by a bug where Edge infinitely recurses on the MutationObserver callback created in include.preload.js. While we'll push to get this fixed on our side, I was wondering if you could explain a little more about why the MutationObserver is necessary and if it would be possible to remove it as a workaround in the meantime. This is causing a number of hangs in Edge across various sites with ABP installed, so we'd like to understand what a fix would look like as soon as possible. Thanks!

comment:7 Changed 3 years ago by sebastian

Yes, we had the same issue with older Chrome versions, where this is fixed now, see #4101. We could backport that fix to Adblock Plus for Edge, which is still based on Adblock Plus 1.12.0, IIRC. Or perhaps we should consider rebasing again soon.

comment:8 Changed 3 years ago by sebastian

  • Cc sebastian added

comment:9 Changed 3 years ago by oleksandr

  • Owner set to oleksandr
  • Review URL(s) modified (diff)

comment:10 Changed 3 years ago by oleksandr

  • Status changed from new to reviewing

comment:12 Changed 3 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:13 Changed 3 years ago by sebastian

  • Milestone set to Adblock-Plus-0.9.7-for-Microsoft-Edge
Note: See TracTickets for help on using tickets.