Opened 3 years ago

Closed 3 years ago

#4266 closed defect (worksforme)

Adblock Plus 0.9.5.0 fails to load filter lists on Edge's first launch

Reported by: scottlow Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: trev, oleksandr Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Microsoft Edge
Adblock Plus 0.9.5.0
Windows 10 Insider Preview

How to reproduce

  1. Install Adblock Plus 0.9.5.0 from the Store
  2. Close Edge
  3. Re-open Edge

...

Observed behaviour

Adblock Plus fails to initialize since filter lists are not pulled down unless they are manually refreshed

Expected behaviour

Adblock Plus initializes as expected

Change History (3)

comment:1 Changed 3 years ago by scottlow

  • Platform changed from Unknown / Cross platform to Edge

comment:2 Changed 3 years ago by trev

  • Cc trev added

This is reproducible for me, the initial download fails - only during browser startup, not if the extension is activated later on.

comment:3 Changed 3 years ago by trev

  • Cc oleksandr added
  • Resolution set to worksforme
  • Status changed from new to closed

As of version 0.9.6 the filters no longer need to be downloaded on startup. That change fixed this issue as a side-effect.

Note: See TracTickets for help on using tickets.