Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4298 closed defect (fixed)

Unblockable ad box on Slickdeals.net

Reported by: rhana@… Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-1.12.2-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: kzar, sebastian, mapx, Ross, scheer Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29349024/

Description (last modified by kzar)

Environment

Windows 10 Home, 64-bit running on a Dell Dimension XPS
Chrome 52.0.2743.82 m (fully up-to-date)
AdBlock 3.1 with AdBlock Custom, EasyList, Malware Protection, Acceptable Ads disabled; filter lists updated today
ABP 1.12.1 with EasyList, Acceptable Ads disabled; filter lists updated today

How to reproduce

  1. Browse to http://slickdeals.net/
  2. Look for the ad box on the right side of the window near the top.

Observed behaviour

There's a Google AdSense ad.

Expected behaviour

There should be no Google AdSense ads with Acceptable Ads disabled.

Notes

Change History (11)

comment:1 Changed 3 years ago by mapx

  • Cc kzar sebastian mapx added

comment:2 follow-up: Changed 3 years ago by mapx

@Rhana, did you ask your developers (adblock 3.1 on chrome) about this issue ? :)

comment:3 Changed 3 years ago by kzar

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Owner set to kzar
  • Platform changed from Chrome to Unknown / Cross platform
  • Priority changed from Unknown to P2
  • Ready set

Can reproduce as described, investigating.

comment:4 Changed 3 years ago by kzar

Looks like they're messing with our element hiding styles, our sheet is still there with all the rules, but the rules no longer have the display: none style. Continuing to investigate...

comment:5 Changed 3 years ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Yep, have come up with a way to make sure display: none isn't tampered with. Works fine for Slickdeals, I'm seeing no ads there now.

comment:6 in reply to: ↑ 2 Changed 3 years ago by rhana@…

Replying to mapx:

@Rhana, did you ask your developers (adblock 3.1 on chrome) about this issue ? :)

Since all the ad-blocking mojo comes from ABP now, no. :) Actually, fanboy of Fanboy's Annoyances suggested reporting it straight to you guys. Here's the post:
https://forums.lanik.us/viewtopic.php?f=62&t=30355&p=99620&hilit=slickdeals&sid=d2d77a8213c3e962e33261d95e13381c#p99620

comment:7 Changed 3 years ago by fanboy

I was more aiming at more chrome/Adblock Plus specific issue here, given Firefox has no issues with the site.

comment:8 Changed 3 years ago by fanboy

Looking at the elements; slickdeals.net##.sideGridBox.ad (This is one in question).

But in Easylist we already have. slickdeals.net##.ad

comment:9 Changed 3 years ago by kzar

(Yea, you don't need to add any more filters. I have a version of the Adblock Plus for Chrome code under review that blocks these ads fine with just EasyList.)

comment:10 Changed 3 years ago by kzar

  • Cc Ross scheer added
  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

(This issue was fixed at the same time as #4191.)

comment:11 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Elements shown in the report/screenshot are now hidden again.

ABP 1.12.1.1642
Chrome 41, 52 / Windows 7

Note: See TracTickets for help on using tickets.