Opened 17 months ago

Closed 17 months ago

Last modified 16 months ago

#4300 closed defect (fixed)

Sitekey whitelisting not working for Safari

Reported by: arthur Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-1.12.2-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian, kzar, Ross, scheer Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29349012/

Description (last modified by kzar)

Environment

OS X 10.11.6
Safari 9.1.2
Adblock Plus devenv built from the latest code (@6a895c3d658d)

These two filters:

ads
@@$sitekey=MFwwDQYJKoZIhvcNAQEBBQADSwAwSAJBANGtTstne7e8MbmDHDiMFkGbcuBgXmiVesGOG3gtYeM1EkrzVhBjGUvKXYE4GLFwqty3v5MuWWbvItUWBTYoVVsCAwEAAQ

How to reproduce

  1. Go to http://sitekey.kzar.co.uk/

Observed behaviour

Images aren't shown.

Expected behaviour

Both images should be shown as they are with Chrome.

Notes

Change History (10)

comment:1 Changed 17 months ago by kzar

  • Cc kzar added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Owner set to kzar
  • Priority changed from Unknown to P2
  • Ready set

Can reproduce, investigating.

comment:2 Changed 17 months ago by kzar

  • Summary changed from Sitekey whitelisting not working to Sitekey whitelisting not working for Safari

comment:3 Changed 17 months ago by kzar

  • Description modified (diff)

comment:4 Changed 17 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Was just a typo, we were sending the filter.addKey message instead of filters.addKey.

comment:5 Changed 17 months ago by abpbot

A commit referencing this issue has landed:
Issue 4300 - Fix typo in $sitekey adding logic

comment:6 Changed 17 months ago by kzar

  • Cc Ross scheer added
  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 16 months ago by scheer

@kzar - Sorry, but to be clear, the two images are one of a cat and one of the ABP logo?

Thanks

comment:8 Changed 16 months ago by kzar

Yep, the expected behaviour is that both images are shown, both the cat and our logo. (The same as if you try it with Chrome.)

comment:9 Changed 16 months ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • Adding the filter whilst all other filter list subscriptions are disabled allows the two images to load as intended.

ABP 1.12.1.1642
OS X 10.11.6
Safari 9.1.2

Note: See TracTickets for help on using tickets.