Opened 3 years ago

Closed 3 weeks ago

#4304 closed defect (rejected)

Bing's "new tab" page renders slowly in Chrome

Reported by: BrentM Assignee:
Priority: P4 Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: sebastian, kzar, mapx Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Environment

Windows 10
Chrome 52.0.2743.82 m (64-bit)
ABP 1.12.1 (& AdBlock 3.1)
Only EasyList enabled

How to reproduce

  1. In Chrome Settings, set the default search engine to Bing
  2. Open a new tab

Observed behaviour

The content on the new tab will take a few seconds to render.

There are several iframes (16 in my testing) on the new tab that get loaded, each requiring the hiding style sheet.

Expected behaviour

With ABP disabled, the content on the new tab takes less than a second to render

Notes

Since there are currently no ads on the 'Bing' new tab page, the following filter will improve the render time on the new tab

@@||www.bing.com/chrome/newtab^$elemhide

We were notified by Microsoft of the performance degradation.

Change History (4)

comment:1 Changed 3 years ago by kzar

  • Cc sebastian kzar added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Platform changed from Unknown / Cross platform to Chrome
  • Priority changed from Unknown to P4
  • Ready set
  • Summary changed from Slow response on new tabs in Chrome Browser with default search engine set to Bing to Bing's "new tab" page renders slowly in Chrome

Can reproduce as described.

comment:2 Changed 3 years ago by mapx

  • Cc mapx added

comment:3 Changed 3 years ago by kzar

  • Description modified (diff)

comment:4 Changed 3 weeks ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.