Opened 3 years ago

Closed 7 months ago

#4308 closed defect (worksforme)

"Block element" does not appear as an option in the menu.

Reported by: zosawnzw Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: oleksandr, sebastian, mapx, Ross, geo Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

OS: Windows 10 build 1607 (14393.10)
Browser: Microsoft Edge 38.14393.0.0 (Microsoft EdgeHTML 14.14393)
AdBlock Plus version: 0.9.6.0
Enabled filter lists: Easy List

How to reproduce

  1. Open Microsoft Edge browser and go to any website with ads
  2. Click the extension button AdBlock Plus with the right mouse button
  3. See AdBlock Plus menu that appears.

Observed behaviour

The "Block element" option, which lets you select and lock a particular element of the page, does not appear within the AdBlock Plus menu in Microsoft Edge browser.

Expected behaviour

The "block element" should be displayed within the AdBlock Plus menu in Microsoft Edge the same way as happens in other browsers (Firefox and Google Chrome).

Attachments (4)

win10.PNG (20.7 KB) - added by zosawnzw 3 years ago.
This is the AdBlock Plus menu in Microsoft Edge which does not have the "Block element".
win10.2.PNG (29.0 KB) - added by zosawnzw 3 years ago.
This is AdBlock Plus menu in Google Chrome that correctly displays the "Block element".
win10.3.PNG (16.3 KB) - added by zosawnzw 3 years ago.
This is the AdBlock Plus configuration page in Microsoft Edge showing that the check box to display the "Block element" in the menu is selected.
missingbutton.png (73.9 KB) - added by KogarashiKaze 2 years ago.
The difference in AdBlock Plus menus between Edge and Chrome, in English.

Download all attachments as: .zip

Change History (12)

Changed 3 years ago by zosawnzw

This is the AdBlock Plus menu in Microsoft Edge which does not have the "Block element".

Changed 3 years ago by zosawnzw

This is AdBlock Plus menu in Google Chrome that correctly displays the "Block element".

Changed 3 years ago by zosawnzw

This is the AdBlock Plus configuration page in Microsoft Edge showing that the check box to display the "Block element" in the menu is selected.

comment:1 Changed 3 years ago by mapx

  • Cc oleksandr sebastian mapx added

comment:2 Changed 2 years ago by mapx

Changed 2 years ago by KogarashiKaze

The difference in AdBlock Plus menus between Edge and Chrome, in English.

comment:3 Changed 2 years ago by KogarashiKaze

"Block Element" also doesn't show up when right-clicking on an element on a web page, even though "Show 'Block Element' right-click menu item" is checked in AdBlock Plus options.

comment:4 Changed 2 years ago by sebastian

  • Component changed from Unknown to Platform

comment:5 Changed 21 months ago by Ross

Reproduced. Block element context menu entry never seems to appear at all.

ABP 0.9.11.1849
Edge 40 / Windows 10

comment:6 Changed 7 months ago by sebastian

  • Cc Ross geo added

Ross, can you check again whether this issue still persists with the current development build?

comment:7 Changed 7 months ago by Ross

This no longer seems to be an issue. I can see Block element in the context menu when right clicking images.

ABP 0.9.11.2206
Edge 42.17134.1.0 / EdgeHTML 17.17134 / Windows 10 (1803)

comment:8 Changed 7 months ago by sebastian

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.