Opened 3 years ago

Closed 2 years ago

#4316 closed defect (worksforme)

Adblock Plus blocks video from rendering on nbcolympics.com

Reported by: scottlow Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian, oleksandr, Ross Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 10 Anniversary Update
Adblock Plus 0.9.6.0 on Edge 38.14393.0.0
Adblock Plus 2.7.3 on Firefox 48.0
EasyList

How to reproduce

  1. Install Adblock Plus on one of the platforms listed above
  2. Navigate to http://www.nbcolympics.com/video/ryan-seacrest-interviews-us-womens-gymnastics-team

...

Observed behaviour

The video loads and audio plays, but the video content itself is blocked by ABP

Expected behaviour

The video is displayed properly

Additional information

  • Adding the custom rule @@*/AdManager.js fixes the problem in both Edge and Firefox (the EasyList rule performing the blocking seems to be ||fwmrm.net^$~object-subrequest,third-party)
  • In Edge, it looks like the <video> is getting a CSS rule display: none !important applied to it. Unchecking the applied style in F12 fixes the issue. In Firefox, the reason for this occurring is unclear based on my quick tests.
  • This does not reproduce in Chrome since Chrome is served Flash video content by NBC

Change History (4)

comment:1 Changed 2 years ago by sebastian

  • Cc oleksandr Ross added

On Chrome and Firefox (using the current Adblock Plus development build), there is an overlay covering the video, telling the user to turn off their ad blocker. This is something that is generally not prevented by EasyList or Adblock Plus, and doing so would be legally problematic.

Ross and Ollie, does the behavior on Microsoft Edge differ here?

comment:2 Changed 2 years ago by sebastian

  • Platform changed from Unknown / Cross platform to Edge

comment:3 Changed 2 years ago by oleksandr

Behavior on Microsoft Edge is the same. There is an overlay covering the video with "Please turn off your ad blocker" message. The page has probably changed since the issue was originally reported too.

comment:4 Changed 2 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.