Opened 3 years ago

Closed 3 years ago

#4319 closed defect (fixed)

Got error status from ['hg', 'status', '--rev', '0^:0', '-u', '.']:

Reported by: juliandoucette Assignee: trev
Priority: P4 Milestone:
Module: Sitescripts Keywords:
Cc: trev, sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29352960/

Description

Environment

OS X El Capitan Version 10.11.6 (15G31)

How to reproduce

  1. clone empty repository hg clone ...
  2. make first commit hg commit -m "..."
  3. try to review first commit hg review -c 0 -w manvel@adblockplus.org -t "..."

Observed behaviour

Got error status from ['hg', 'status', '--rev', '0:0', '-u', '.']:

Expected behaviour

Review uploaded.

Change History (6)

comment:1 Changed 3 years ago by trev

For reference, selecting the correct revision range here is possible with -r 00000000:0 but I see a way to select any changeset in a generic way (0^:0 fails because the initial commit doesn't have a parent so this range is empty).

comment:2 Changed 3 years ago by trev

  • Owner set to trev

comment:3 Changed 3 years ago by trev

I thought that I solved this - 0^+null+0 and 1^+null+1 produce correct results with both hg diff and hg status. However, upload.py also uses hg cat in order to retrieve the base files. While it recognizes the a:b for for revision sets and extracts the base revision correctly then, anything more advanced won't work. I also tried (0^+null):0 and (1^+null):1, but hg cat --rev '(1^+null)' won't work correctly either.

comment:4 Changed 3 years ago by trev

  • Priority changed from Unknown to P4
  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4319 - [hgreview Make sure reviews for the initial repository revision can be created]

comment:6 Changed 3 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.