Opened 3 years ago

Closed 2 years ago

#4325 closed defect (worksforme)

Adblock Plus 0.9.6.0 Breaks YouTube Filters in Edge

Reported by: scottlow Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian, oleksandr, Ross Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows Insider Preview
Microsoft Edge 14
Adblock Plus 0.9.6.0

How to reproduce

  1. Install Adblock Plus from the Windows Store
  2. Navigate to Youtube.com
  3. Search for something in the search bar
  4. Try clicking the "Filters" dropdown immediately under the search bar

...

Observed behaviour

The "Filters" dropdown does not open to reveal filter options

Expected behaviour

The "Filters" dropdown opens to reveal filter options

Additional information

This does not reproduce with Adblock 0.9.3.0, so it looks to be a regression between versions.

Change History (7)

comment:1 Changed 3 years ago by sebastian

  • Cc oleksandr added

comment:2 Changed 3 years ago by sebastian

Just to clarify, is this something that you'd expect us to fix soon? Or would we even be able to update Adblock Plus within the next weeks, to fix this? Since you told us that you want to keep the extensions on the Windows Store in a stable state for now.

We will of course look into that issue regardless.

comment:3 Changed 3 years ago by scottlow

I believe the freeze is still on for another two weeks, so no. This isn't an issue that needs to be addressed immediately, but we wanted to let you know so it's on your radar.

comment:4 Changed 3 years ago by scottlow

We're continuing to receive reports on this. We suspect it may be because window.onload does not fire properly due to a bug in Edge with ad blockers enabled. We're working on a fix, but in the meantime, a potential workaround that works with YouTube is to trigger a load event on the window to kick off YouTube's scheduler which in turn loads content correctly.

comment:5 Changed 2 years ago by sebastian

  • Cc Ross added

Ross and Ollie, can you check whether this is still reproducible as of the current development build?

comment:6 Changed 2 years ago by oleksandr

Not reproducible on the current development build. However I think YouTube has also changed layout since.

comment:7 Changed 2 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.