Opened 3 years ago

Closed 3 years ago

Last modified 15 months ago

#4351 closed defect (fixed)

Video ads on YouTube are not blocked using Safari 6 (Flash)

Reported by: rraceanu Assignee:
Priority: P4 Milestone: Adblock-Plus-1.12.4-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: kzar, rraceanu, sebastian, Ross Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29356615/

Description (last modified by kzar)

Environment

Safari 6.0 (doesn't occur on higher Safari versions)
OS X 10.8
ABP 1.21.1.1644 / 1.21.1
Easylist and AA

How to reproduce

  1. Open https://www.youtube.com/watch?v=0HGenoCF8Js / https://www.youtube.com/watch?v=kOkQ4T5WO9E
  2. Might need to navigate to other videos from the sidebar to get an ad.

Observed behaviour

Pre-roll video ad is displayed.

Expected behaviour

Video ads should be blocked.

Notes

Change History (9)

comment:1 Changed 3 years ago by rraceanu

  • Description modified (diff)

comment:2 Changed 3 years ago by kzar

  • Cc sebastian Ross added

This seems to be similar to #4141, but since Robert reports it also happens with 1.12.1 and that no error is displayed in the console that doesn't make sense. Perhaps our Flash YouTube blocking solution just doesn't work 100% of the time?

comment:3 Changed 3 years ago by kzar

  • Description modified (diff)

Robert has noticed there are actually exceptions being displayed, I've updated the issue. Certainly doesn't look like a recent regression in any case.

comment:4 Changed 3 years ago by kzar

  • Priority changed from Unknown to P4
  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4351 - Check History variable exists

comment:6 Changed 3 years ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

Robert please can you confirm this change fixes the problem? Since I couldn't easily reproduce the problem and the fix was so obvious I took the unusual step of pushing a fix anyway. If the problem remains for you we'll have to revert this.

comment:7 Changed 3 years ago by rraceanu

Issue no longer occurs on 1.12.2.1670 / OS 10.8 / Safari 6 / Easylist.

comment:8 Changed 3 years ago by rraceanu

  • Verified working set

comment:9 Changed 15 months ago by plantsower

I have ADP 1.12.4, Safari 11.1 and Sierra 10.12.6. ADP does not block any adds in YouTube. If anything it's worse. Is there a fix yet? Thanks.

Note: See TracTickets for help on using tickets.