Opened 3 years ago

Closed 3 years ago

#4360 closed change (fixed)

"Get whitelisted" page of new Acceptable Ads website

Reported by: saroyanm Assignee: saroyanm
Priority: P2 Milestone:
Module: Websites Keywords:
Cc: jobp, christiane, athornburgh Blocked By: #4270
Blocking: #4263 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29351571/

Description (last modified by saroyanm)

Background

As mentioned in #4263 we are planing to launch new website for Acceptable Ads and with #4270 we are creating initial structure of the website.

What to change

Use current style guide to create the paged using content/information below:

  • Page Url pattern: /solutions/get-whitelisted?type=*
  • headline text/title: Get whitelisted
  • First paragraph text: We love the Internet, but we think it can improve. Help us make it a better place!
  • Second paragraph text: The Acceptable Ads initiative ​ is simple: if your ads are non-intrusive and abide by our criteria, they will be seen by a much larger audience, thus increasing your traffic and revenue. Many advertisers and publishers already benefit from using Acceptable Ads. If you want to be one of them, read our guidelines and fill out the form.
  • Form labels:
    • Email Address
    • First Name
    • Last Name
    • Job Title (optional only for publishers)
    • Company Name (optional only for publishers)
    • Partner Type
      • Publishers
      • Ad Networks
      • Advertisers
      • Ad Tech suppliers
    • Company Website (optional)
    • Exact URL with acceptable ads
      • Add another URL
        • Exact second URL with acceptable ads (optional)
        • Exact third URL with acceptable ads (optional)
    • Comments (optional)
  • Text below the form: By submitting your application, you confirm that you have read the Acceptable Ads criteria and that ads on your website comply with them.
  • Clear button text: CLEAR
  • Submit button text: SUBMIT
  • Privacy policy text below the buttons: Privacy policy: Your information will be stored and used only to handle this application and to respond to your inquiry. It will never be shared with any third party. If you would like to have your information removed from our database, please email us at acceptableads@….
  • Right side widget
    • Icon: Icon
    • Title: NOTE
    • Body text: Before applying, please ensure that your ads comply with all of our criteria, including these general guidelines:
    • List below body text:
      • No animation, it has to be static
      • Preferably text-only
      • Labeled as ads
      • Clearly separated from the content

Form Behavior

Please modify current submit form generated by sugar CRM with the information below:

  • According which option is selected from "Partner Type" select box current fields should be visible:
    • Publishers
      • Company Name
      • First Name
      • Last Name
      • Job Title
      • Company Website
      • Email Address
      • Exact URL with acceptable ads
      • Exact second URL with acceptable ads
      • Exact third URL with acceptable ads
      • Comments
    • Ad Networks
      • Company Name
      • First Name
      • Last Name
      • Job Title
      • Company Website
      • Email Address
      • Comments
    • Advertisers
      • Company Name
      • First Name
      • Last Name
      • Job Title
      • Company Website
      • Email Address
      • Comments
    • Ad Tech suppliers
      • Company Name
      • First Name
      • Last Name
      • Job Title
      • Company Website
      • Email Address
      • Comments

Attachments (3)

2.0.1_Styleguide.png (79.6 KB) - added by saroyanm 3 years ago.
WebToLeadForm.html (10.4 KB) - added by saroyanm 3 years ago.
AA_Assets-Icon_Publishers.png (1.1 KB) - added by saroyanm 3 years ago.

Download all attachments as: .zip

Change History (25)

Changed 3 years ago by saroyanm

Changed 3 years ago by saroyanm

comment:1 Changed 3 years ago by saroyanm

  • Description modified (diff)

Changed 3 years ago by saroyanm

comment:2 Changed 3 years ago by saroyanm

  • Description modified (diff)

comment:3 follow-up: Changed 3 years ago by saroyanm

  • Cc jobp christiane athornburgh added

Couple of questions:
@Job:

  • As you can see in the styleguide we have a rightside widget, which should be generic enough while we don't want to duplicate this form for each separate "Partner Type", according to the Design the widget suppose to have title of the "Partner type", but I made it to smth. generic Note: (please let me know if you fine with the label)
  • We currently missing couple of text here from original form (please let me know if they are crutial and we still need to have them here, not sure if that was intentional during wireframes generation):
    • If you would like to report falsely blocked content (no ads) or broken functionality due to Adblock Plus, please use our Firefox issue report tool instead.
    • We've been running an open source adblocker since 2006, and we know that lots of websites depend on ads; however, we also know that users won't accept flashy banners. We see a solution: In our years of adblocking we've learned that most users actually don't mind seeing better, more informative ads.

@Aaron, @Christiane: We have another field Job Title can you please give me a hint where it needs to be placed ?

comment:4 in reply to: ↑ 3 Changed 3 years ago by saroyanm

  • Priority changed from Unknown to P1
  • Ready set

Replying to saroyanm:

Couple of questions:
@Job:

  • As you can see in the styleguide we have a rightside widget, which should be generic enough while we don't want to duplicate this form for each separate "Partner Type", according to the Design the widget suppose to have title of the "Partner type", but I made it to smth. generic Note: (please let me know if you fine with the label)
  • We currently missing couple of text here from original form (please let me know if they are crutial and we still need to have them here, not sure if that was intentional during wireframes generation):
    • If you would like to report falsely blocked content (no ads) or broken functionality due to Adblock Plus, please use our Firefox issue report tool instead.
    • We've been running an open source adblocker since 2006, and we know that lots of websites depend on ads; however, we also know that users won't accept flashy banners. We see a solution: In our years of adblocking we've learned that most users actually don't mind seeing better, more informative ads.

@Aaron, @Christiane: We have another field Job Title can you please give me a hint where it needs to be placed ?

Aligned with Job and the way it is described in ticket is fine, we can keep generic "Note:" and current text is fine.

comment:5 Changed 3 years ago by jobp

P1 confirmed, this is critical for lead generation.

comment:6 Changed 3 years ago by saroyanm

  • Description modified (diff)

comment:7 Changed 3 years ago by saroyanm

  • Description modified (diff)

comment:8 Changed 3 years ago by saroyanm

@Job I've marked "Job Title" and "Company name" as optional, for the initial implementation, please let me know if they are crucial to be required for non "Publishers" group. This will make initial implementation easier.
Note: we also need to setup in CRM to make the "acceptable ads url" optional for future implementation.

comment:9 Changed 3 years ago by saroyanm

  • Description modified (diff)

@Job forget previous comment, implemented already.

comment:10 Changed 3 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:11 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4360 - Created 'Get whitelisted' page form and functionality

comment:12 Changed 3 years ago by saroyanm

  • Owner set to saroyanm

comment:13 Changed 3 years ago by jobp

Page Title: Get whitelisted and monetize your ad blocking audience
Page Description: Have Acceptable Ads? Apply now to get your ads whitelisted and start monetizing!

comment:14 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4360 - fixed ugly alert notifications

comment:15 Changed 3 years ago by abpbot

comment:16 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4360 - Updated the fields with the new generated one

comment:17 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
issue 4360 - Uploaded the thank you page

comment:18 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
issue 4360 - added links to criteria page

comment:19 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
issue 4360 - Fixed links to the criteria page

comment:20 Changed 3 years ago by saroyanm

  • Sensitive unset

comment:21 Changed 3 years ago by juliandoucette

  • Priority changed from P1 to P2

comment:22 Changed 3 years ago by juliandoucette

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.