Opened 15 months ago

Closed 15 months ago

Last modified 13 months ago

#4364 closed change (fixed)

Drop support for Chrome 29-40 and remove legacy code

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.12.4-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29350213

Description (last modified by sebastian)

Background

Currently, Adblock Plus supports Chrome 29 trough the latest version (i.e. 54 dev). Testing all those versions became virtually impossible. Moreover, we have a couple workarounds for older versions, we'd like to get rid of. Also considering the low users numbers for Chrome 29-40 (including other Chromium based browsers), i.e. 0.7% of Adblock Plus users on Chromium-based browsers, we decided to unsupport those versions and remove the legacy code.

What to change

  • Advance minimum_chrome_version to 41.0
  • Remove workaround to detect top-level documents on Chrome 29.
  • Remove workaround dealing with anonymous frames on Chrome <=40 and get rid of the init() function. Refactoring the element hiding code into a class seems sensible.

Change History (5)

comment:1 Changed 15 months ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 15 months ago by sebastian

  • Description modified (diff)

comment:3 Changed 15 months ago by abpbot

A commit referencing this issue has landed:
Issue 4364 - Drop support for Chrome 29-40 and remove legacy code

comment:4 Changed 15 months ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 13 months ago by rraceanu

  • Verified working set

No longer able to install ABP on Chrome <41, User will receive the message "Package is invalid. Details: This extension requires Google Chrome version 41.0 or greater", verified on ABP version 1.12.2.1670, Chrome 39.

Note: See TracTickets for help on using tickets.