Opened 3 years ago

Closed 3 years ago

#4369 closed defect (duplicate)

abp-properties exception filter ignored in blockable items list

Reported by: mapx Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, arthur Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mapx)

Environment

Windows 7
Firefox 49.0b6
ABP 2.7.3.4197
easylist + easy germany

How to reproduce

  • Open the list of blockable items
  • in the list note this filter:

runnersworld.de###statsdiv + [-abp-properties='position: relative;']

  • add these custom filters (removing the ads on top / right side, the first filter necessary due to blank page):

runnersworld.de#@##statsdiv + [-abp-properties='position: relative;']
@@||runnersworld.de^$generichide

Observed behaviour

the first exception filter is not listed in the blockable items

Expected behaviour

It should appear in the blockable items.

Change History (3)

comment:1 Changed 3 years ago by mapx

  • Description modified (diff)

comment:2 Changed 3 years ago by mapx

  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Platform changed from Unknown / Cross platform to Firefox

comment:3 Changed 3 years ago by trev

  • Resolution set to duplicate
  • Status changed from new to closed

This is consistent with other element hiding exception rules now - we apply those before we can know whether the filter in question matches anything on the current page, so the usual hit counting approaches won't work. While we could still count them for CSS property rules, if #3969 is resolved the way Sebastian proposes it (only count CSS property rules when they affect an element of the page) this won't work any more. We need a new approach, resolving this as a duplicate of #4509.

Note: See TracTickets for help on using tickets.