Opened 3 years ago

Closed 3 years ago

#4373 closed change (fixed)

Make jsHydra compatible with Python 3

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone:
Module: Automation Keywords:
Cc: Blocked By:
Blocking: #4374, #4375 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29350236

Description (last modified by sebastian)

Background

We are currently in the progress of migrating our code base to Python 3. And with jshydra being a dependency of buildtools this is where to start.

What to change

Make all Python code in the jshydra repository, that is abp_rewrite.py, utils.py and autotest.py, compatible with Python 3.5, while keeping the code also compatible with PYthon 2.7. Also add a tox.ini to make testing easier.

Change History (6)

comment:1 Changed 3 years ago by sebastian

  • Description modified (diff)

comment:2 Changed 3 years ago by sebastian

  • Blocking 4374 added

comment:3 Changed 3 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 3 years ago by sebastian

  • Blocking 4375 added

comment:5 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 4373 - Made jshydra compatible with Python 3

comment:6 Changed 3 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.